Im confused he wont change jobs


wait 3 mins and
Steps to reproduce:

  1. follow the screen shots
  2. profit

Expected Results:
job change to archer
Actual Results:
last screenshot



Version Number and Mods in use:
latest unstable no mods

How many Hearthlings do you have?
Having a lot of people tend to bogg down the game quite a lot, and theses issues has happened for a while when the game has more Hearthlings than what the computer can handle

Some solutions are to reload the game or pause it for a few moments(30seconds at max it seems) and see if it’s resolved

24 gb ram and a 750 ti gp[u my machine can handle over 300 hearthings right nwo im only at 20 and all other jobs are changing fine just that one hearthing is refusing to change to an archerer

Whoa, that’s one powerfull PC!

If that’s the case, i suppose it really is a new or different issue

I’m paging @yshan
Could you upload your save so she can take a look when she’s around?

yea (7.6 MB)
i need 25 archereers for this save hes the second footrman to reach the level high enough to be an archerer and i have 3 bows as you saw by the screenshots he has everything required to become archerer

i gound a work around to the problem but it shouldent be a problem at all (the talisman was in the town inventory and i had to put it in a stockpile for the stupid hearthings to use it odd)

Hmm. Looking at the save it appears that the bows were in a stockpile at one point, but have been filtered out. There is no stockpile for them to be moved to. I’m not sure, but I wonder if that could be preventing the footman from “seeing” it, as you discovered it worked when you put it in a stockpile.

all other talismans are able to be :seen: by eveyone else and used reguaidless of being in a stockpile

That was purely a guess, I am not 100% sure. I tried to reproduce this myself in a microworld, but as you see with all your other talismans, my footman could always promote to an archer even when the bow wasn’t in a container.

microworld?? devtestworld or something

Microworld is a tiny world that can be used to load things quickly and do testing. If you’ve ever seen a dev stream it’s very similar what they use for their testing. You can download it from github: GitHub - stonehearth/microworld: Microworld Stonehearth Mod

yea i watch every devstream bu8t didnt knwo the mucroworld was available to the public

1 Like

I actually had a similar issue yesterday. This screenshot shows a trappers knife stuck on the masons pedestal. I could not promote a hearthling to a trapper because he would not pick up the knfe from the pedestal. They also would not remove from the pedestal. I actually tried moving the pedestal (it was next to the workbench in the screenshot) and the trappers knife stayed on it. I had to make a second knife to get them to move the first one. After that they put the second on in the inventory just fine. Sadly, I deleted that save already so I can’t provide it.

1 Like