Hearthling Idles & Tons of Errors

resolved

#1

Summary:
Getting loads of errors on my latest youtube town it’s very frustrating and it seems that now all my people just idle and when i tried to load the game that i just saved the entire game crashed and made me have to restart the game. but the people they just idle around i see no reason other than some kind of bug.
Attaching screenshots on the vast amounts of bugs when loading the game.

Steps to reproduce:
1)
2)
3)

Expected Results:
People working and not idling

Actual Results:
people idling not building or doing their work

Notes:
Not sure what’s going on this latest build is extremely buggy with buildings and things that you cant break such as crypts.
not sure what i should do if i need to restart again…

Attachments:






Version Number and Mods in use:
Steam Latest Alpha 16 2940

Mods
Sprios Windows
Jomaxro Doorways
Endpieces

System Information:
Windows 10 x64
Amd 7950
i7 920@3.8ghz
12GB DDR3
Samsung 840,830
WD 1TBx2
WD 4TB


#2

Did you start a new game in alpha 16 or was it an old save from before alpha 16?
Are all your mods up to date?
Do you get the same error message without the mods?

Maby uploading the save so we can have a look and see if we get it too?


#3

Started a brand new game with this Town.
Just removed the mods just to see and it threw 12 errors now upon loading the game instead of 6.
Made a new save after the mods was removed and back to 6 errors.

Save File
brokensaveBanto.zip (8.0 MB)

ERROR INFO

1
develop-2940 (x64)…ices/client/renderer/construction_render_tracker.lua:20: attempt to index field ‘_bp’ (a nil value)stack traceback:
[C]: ?
…ices/client/renderer/construction_render_tracker.lua:20: in function '__user_init’
radiant/lib/unclasslib.lua:270: in function '__init’
radiant/lib/unclasslib.lua:201: in function ‘ConstructionRenderTracker’
…ers/construction_data/construction_data_renderer.lua:23: in function <…ers/construction_data/construction_data_renderer.lua:11>

2
develop-2940 (x64)c++ exception: lua runtime errorstack traceback:

3
develop-2940 (x64)…ehearth/renderers/fabricator/fabricator_renderer.lua:23: assertion failed!stack traceback:
[C]: ?
[C]: in function ‘assert’
…ehearth/renderers/fabricator/fabricator_renderer.lua:23: in function <…ehearth/renderers/fabricator/fabricator_renderer.lua:13>

4
develop-2940 (x64)…onehearth/components/building/building_component.lua:154: attempt to index local ‘entry’ (a nil value)stack traceback:
[C]: ?
…onehearth/components/building/building_component.lua:154: in function ‘get_dependencies’
…/fixture_fabricator/fixture_fabricator_component.lua:163: in function ‘_are_dependencies_satisfied’
…/fixture_fabricator/fixture_fabricator_component.lua:202: in function ‘_start_project’
…/fixture_fabricator/fixture_fabricator_component.lua:41: in function <…/fixture_fabricator/fixture_fabricator_component.lua:39>

5
develop-2940 (x64)c++ exception: lua runtime errorstack traceback:

6
develop-2940 (x64)radiant/modules/events.lua:83: assertion failed!stack traceback:
radiant/modules/common.lua:237: in function 'report_traceback’
radiant/modules/common.lua:248: in function <radiant/modules/common.lua:242>
[C]: in function 'assert’
radiant/modules/events.lua:83: in function ‘listen’
…h/components/entity_forms/entity_forms_component.lua:459: in function ‘_trace_ghost_pre_destroy’
…h/components/entity_forms/entity_forms_component.lua:466: in function ‘_start_placement_task’
…h/components/entity_forms/entity_forms_component.lua:64: in function 'obj’
radiant/modules/events.lua:73: in function 'instance’
radiant/modules/events.lua:206: in function <radiant/modules/events.lua:200>
[C]: in function 'xpcall’
radiant/modules/common.lua:257: in function 'xpcall’
radiant/modules/events.lua:200: in function <radiant/modules/events.lua:171>

People just idling around really strange i think this save might already be totally broken :’(


#4

Started to wonder if this things can have to do with designing interior rooms for the houses because when i think about it this is something i started to do kinda recently and these bugs have surfaced recently also.

I instant built one of the houses and went down to 4 errors instead


#5

not sure why but i have seen more players having issue’s with the inside building. Sometimes its just as simple as 1 villager needing the space another villager is using. The game trows a tandrem because its not sure on what it is supposed to do.

I think the quick solution would be to limit you interior work and add small steps to each build to find what specificly is causing the issue or just leaving the interior out because the outside builds are awesome enough :slight_smile:

Edit:
Played around with your savefile. Even removing all the buildings keeps 3 error messages. Made saves of the build and started a new game. Your first building errorred the moment the start building the second floor. Removed the single pillar below the stairs and no issue building it. Perhaps an issue with placing scaffolding for the stairs and up. Also the height of your citizens plays a roll in wether they can reach a spot or not. That to will give issues sometimes.

Will try your other builds to to see what gives the issue


#6

Started of on the second building in a new game ( just to make sure there are no hidden bugs heheheh )

They seem to build the home with that extra roof edge with out fail. Just like the first one the only difference is that i don’t have any of the furniture ready yet. I have seen reports of furniture being placed before the build is complete and giving trouble, but not sure if the dev’s fixed that already so not sure wether that is still an issue.

the thirth building (the one designed but not build) is being done with out an issue. No error message or stalled building.

It seems to me that there are no specific issue’s with your builds wether only outside as well with the insides. Perhaps waiting with placing furniture in your builds will help keep some of the bugs away. Also keeping the area below a stairway free or making it a solid would be an idea you could play with.


#7

Thanks man for putting your time to test it our appreciate it a lot! :slight_smile:
Maybe i will try without some of the Furniture’s for the future to potentially avoid some of these bugs.

These stairways with pillars under is something i started with recently so maybe that creates issues


#8

@Banto thanks for the detailed info. @not_owen_wilson (our building guru) asks that you try building without including any mods – especially since you’re in the latest unstable build, it’s less likely that any mod is updated to work with A16…

Please let us know how that goes.


#9

Thanks very much will try and see if it gets more stable with the building.
Removed the mods from the current town affected but i wonder how it works with the current state of the game if you used a mod and you remove it will it corrupt saves or will game handle it and make it normal even when removing mods?


#10

@Banto it really depends on what the mod is, um, modifying. For example, if you tried to load a save that was started with an event mod (like Candledark or Frostfeast) the save simply won’t load because the mod involves some fairly complex changes to the game.

For something like the windows/doorways mods, assuming that all they do is introduce new window or door types (I’m not familiar with them myself) then the save should load with no problem – but any buildings that used the custom windows/doors introduced by the mods will likely have empty spaces in place of the windows/doors. There is no “autoreplace” feature in the game that would compensate for missing items introduced by mods.