Alpha 10 bugs / Glitches

So I was making a beautiful little town, Little did I know what my hearthling would do next would destroy my world.

So he Decided to stay upstairs and get himself stuck. So I tried to erase the floor, It turned out removing 4 blocks of the second floor wasn’t going to work. So they started to build all the scaffolding again, Realized they where building it for no reason cause they couldn’t reach it. Then this bug made the game unplayable:

Before this happened the same hearthling decided he wanted to build structures his way this was the result:

Honestly, This one I have no idea about just happened out of no where

Not sure if he planned to have his own secret base up there, and thought if there was no windows or doors he can’t be seen so he get out of work!

Also simular to this, Hearthlings will build walls through floors or floors through walls. Which doesn’t break anything just looks weird.

So I found some more yay! :wink:

1st when you accept a trade offer it doesn’t present the time correctly after accepting the offer.

Zombies spawning in peaceful that’s been reported umm I think that’s all I’ve found so far haha.

Sorry If I’m posting to many errors in 1 place, If I am I’ll try moving them to there own threads.


So I found two new issues,

One when making paths, roads or anything that requires mining and placing, Hearthlings will place things without mining first then another hearthling will remove the grass or area that needs to be mined.

The other is a slight issue that Tom found on a live stream but this time it spammed out errors. When you place things over / close to water Hearthlings build scaffolding in the water.

So I tried to place a little border around the water and for some reason (guessing they didn’t have enough room) I got all these errors.

Ill add my bug, It seem I can not build buildings, I get a colour error.

Note, I have uninstalled the game and reinstalled, it still happends. (only thing I have not is found the folder where It saves buildings and delete that datafolder too…

Sorry if this is mentioned else where I am not trying to make you read the same thing several times but I didn’t find any posting on this topic, yet.

SO far I am not having issues with resource gathering or building construction. The only issue I am having is assigning my villagers to become farmers they just won’t do it. I assigned one to do one while they were constructing a house but all they did was keep building. I then waited till it was done and reassigned the villager to become a farmer. Still no change in job. Then I got a new villager and tried to assign them to farmer and yet again they didn’t take up the job. I then waited till there was no more work for the villagers to do (moving stuff to stock piles) and repeated the process still there was no change. I had 2 hoes waiting to be used during this whole time.


Hey thanks for the report, Although this thread is as derailed and off topic as it could possibly be, This isn’t the right place to post it.

I’ve had a quick look around for similar topics and can’t seem to find a match, I’d suggest making it into its own topic so moderators and devs can see. :smile:

1 Like

well there was another report about other jobs not becoming/accepting their new profession, dont know where that one is, and it might have been from an unstable alpha 10 build.

edit: found it! and it also has to do with the farmer :smile:

@SteveAdamo @Relyss please move that post :blush:

1 Like

Thanks for finding that!

I think this thread should probably be closed now, To prevent this happening again, My fault the title was misleading.

Thanks :wink:

1 Like

shame on you @Stoneheartfan :wink:

1 Like

I just keep messing up don’t I? haha I’ll be sure not to mess up next time, I promise! :wink:

you better, or youll end up just like that little boy… :wink:

Oh no… I’ve heard horrible story’s from when you get upset… I shall not go down that road for 2 reasons, 1: I haven’t yet built the road, 2: I won’t mess up next time, No reason to get upset umm yeah… says with fear We good?

1 Like

[quote=“Stoneheartfan, post:11, topic:11948”]
We good?
[/quote]we good man! :smile:

1 Like