Game Won't Load/Launch On New PC *SOLVED*

Brought a brand new PC and decided to redownload steam and then the game. I’ve played it for years and ran on my old gaming desktop without issues for years. Go to launch the game through Steam and the play button turns into “launching” but literally, three seconds later it stops, check task manager as tried loading it up again, it didn’t even attempt to load/launch.

I’ve looked at forms, steams own form page, and much more to see last month people who get new PCs/Laptops been having the issue and followed through with the suggestions below:
-Reinstalling The Game, ensured to have files deleted and reinstalled but no luck
-Unsubscribing from mods from steam, an issue/bug from years ago made me try it early on, nada
-Launching directly from the local files, nope
-Checked anti-virus, nopes
-Checked for updates, windows & drives, NOPE,
-Went into the “user_settings.JSON” since turning off fullscreen was an old bug but yet again nothing, instead, it proved that there were files not made yet since it was never launched because all that was inside the user ID, that alone
-Checked if something plugged into the USB slots bug was still around, nada
-Someone even said to restart PC & Steam multiple times, so did end up trying just in case! Nothing.
-Clearing appcache, still a big old nope
-Validating files
-Waited 24 hours and tried to play it, with steam online and offline mode. Both didn’t work.

Can’t do the F5 trick if nothing lodes at all, the thing is, if I switch the steam settings to work with the old “legacy_vista” it will load that just fine. It will work, run smoothly without lag or issues fine but you can’t really use ACE mods etc with that version at all, it’s more outdated since it’s the old base game when first came out and not the ideal choice. I know that Steam itself has an issue similar but if it was that it would be more than one single game, every other game works fine, without issue, has to be Stonehearth itself.

I’m out of ideas, fully, most people who have posted forms have ‘laptops’ and webcams and things CAN stop the game from working too, this isn’t a laptop, don’t own a webcam. Any new ideas would be welcomed
,
Steps to reproduce:

Get a new PC and see if it downloads!

Expected Results:

To Load the game? To work possibly?

Actual Results:

Read the summary at the top again ^^

Attachments:

There isn’t a crash or log file, because it game has NEVER been LAUNCHED once so there isn’t anything to log or put in a crash file. Since the game has never been launched there ISN’T a crash.dmp file or Stonehearth.log file at all.

System Information:
Using Windows 10 (I checked all up to date),
NVIDIA GeForce RTX 3070 (drivers are up to date as well, the first thing I did when I got the new PC to install windows 10),
i7-11700k processor @ 3.60GHz,
Bulldog Security (have checked, firewalls and that are NOT the issue, had that on old PC and so I checked for this problem),
64-bit operating system

I think this is the first problem for anyone who starts the game in a new space or on a new computer.

When I got this problem, I said, “If it’s not opening, I’ll play another game and play tomorrow.”
When I opened my laptob the next day, the game was working. I don’t know how, but I’m telling you this as an experience. I’m not saying it’s going to work for sure☺️.

Wait until the next day and sadly nothing :sob:
The only difference is that instead of trying to launch/load for 3 seconds it’s gotten longer and tries to run for 6 seconds now, but still no luck at all with it launching

Does the game generate a log file ? Maybe this will tell you what is going on.
stonehearth.log, it should be in the same folder as the exe.

As I explained in the post, there isn’t a log file because the game needs to at least be launched once to create one. It’s hasn’t generated because it’s never launched or ran, so there isn’t one at all, even the user_settings.JSON file isn’t got the full correct information on it because it hasn’t ever been launched. It can’t generate anything if it never has ever loaded at all :sweat:

I tried to remember what I was doing after that. And I found it!
I started Steam offline and was able to get into the game.

But again, I don’t know if that’s a definitive solution. Once it happens, it doesn’t happen again, but I can’t say for sure until it does.

Just gave offline a chance but to no luck, maybe Stonehearth has finally died for me at this point :sob:

Have you tried asking the game’s producers?
I don’t know how, but there’s always a support email address, right?

When you email Radiant, they remind you they abandoned/dumped the game back in 2018, so they don’t expect it to work with newer systems sooner or later. This form and steam community page is the only real place you get help with these issues. Radiant left this game to die out but the community made the ACE mod to keep it alive and done really well, so sadly they won’t be much help since they wish to make this game look like it never happened in the first place.

Why would they do that?
If this is the case, you should seek help from forum administrators.

Well, the company the game was under got brought out by a bigger company, they didn’t think the game would get them profit so they canceled it in 2018. Now they don’t have anyone to work on it, who did really work on it etc around, so that’s why they do it, they scrapped the game and when that happens the company try to never mention it again, it happens pretty often too small games like Stonehearth.

I’ve never used these forms before this issue, I normally use the community forms on steam but everyone there also has the same problem as me with no idea how to fix it, so not sure how to get in touch with forum admins, but will see if I can figure it out, thanks for trying to help though!

Click on the 3 lines next to “Discussion” at the top of the site and find moderators from groups and type in one of them, and they may be able to contact you with knowledgeable people.

I hope it works and I can get your own story or buildings

@admins not 100% sure this okay or not, but if any of you have the time to read this, would forever be thankful, let me know if ya know asking for you guys like this is cool or not…

I’m afraid you won’t get any response from admins. The game has been officially out of support for years. From your list it looks like you’ve tried most of the common approaches. Last things to try are to run the 32-bit version, or to disable Real-time protection in the Windows security settings. If that doesn’t work, I’d go to the ACE Discord server. That’s the one place where the game is being kept alive, so the folks there may be able to help.

1 Like

Running it with the 32-bit actually worked! It’s working fine and smooth again! Though to get it to load in 32-bit I had to mess with the files but worked great. I forgot that you could run the game in 32-bit altogether so thanks for the missing piece to fix the files!

1 Like

What happy news for you that we will be happy to see your buildings soon☺️

How do you download the 32 bit version on steam? im struggling with the same problem

You don’t download it, I’m gonna explain a bit of lengthy instructions, I’m not the best but managed to help others. The first task is to trick the coding and your PC that the game has already ran at least once. So follow this instructions closely:

Go to your Steam\steamapps\common\Stonehearth folder, click the user_settings.JSON file. Copy or write down your user ID inbetween the " in a separate notepad. Then once you have that small line of letters, numbers and - saved and written down, copy and paste this in the file, replacing “your_user_id” with the one that already exists in the file (the Id I said to write down/copy somewhere).

{
“user_id” : “your_user_id”,
“alpha_welcome” : {
“hide” : true
},
“enable_auto_save” : false,
“renderer” : {
“run_once” : true,
“use_high_quality” : false,
“enable_ssao” : false,
“enable_shadows” : true,
“msaa_samples” : 0,
“shadow_quality” : 1,
“max_lights” : 50,
“enable_vsync” : false,
“enable_fullscreen” : false,
“screen_width” : 1920,
“screen_height” : 1018,
“draw_distance” : 1000,
“last_window_x” : -8,
“last_window_y” : -8,
“last_screen_x” : 8,
“last_screen_y” : 52
},
“audio” : {
“bgm_volume” : 0,
“efx_volume” : 1
},
“force_32_bit” : false,
“language” : “en”,
“enable_auto_save” : false,
“tutorial” : {
“hideStartingTutorial” : true
}
}

Try launching the game. IT WILL FAIL but it will trick steam into thinking it launched once and finally give the files needed to fix the issue. Once it fails click back on the same file user_settings.JSON and you will see it’s changed. Scroll down to the bottom part and you should now finally see “force_32_bit” : false, CHANGE false, to true, then try launching the game again, the 64 bit has issues with something in windows 10s but the 32 bit is fine, there isn’t much difference in the games other than how fast it takes to load a save.

I do suck at explaining things, if what I explained is not good enough, I can and happily can screen share it through discord to show you what I mean and how I did it. It’s important you copied/written down your original user ID because that being wrong in the slightest is what will make it go wrong, I’ve had 3 people not copy all of it, or ‘fat-fingered’ and added numbers to it the last couple of days (been helping on the steam discussion pages). Let me know if it doesn’t work or if it does! I’ve now been chatting with people about this issue and how it’s different answers depending on if you own a laptop or an actual desktop.

1 Like

Hi ive been having the same issue since i also got a new pc, tried everything you have as well as the user_settings.JSON fix, when i try to run the game i wont start and user_setting.JSON will be changed back to its original text. is there a way to get around this? thanks for any support

I just randomly found a possible fix, i removed the x64 folder from common/stonehearth and the game now runs without issue, also runs with ACE

1 Like