Game Goes to radiant logo screen when loading save

I dont know how but my game Goes to the radiant logo screen when i load my save it does it with every save i got. Can anyone help me with this?

Welcome to the forum, @Movecraft_Pirates :slight_smile:

Let’s see… Are you playing in 32 or 64bit?

Is your save from a previous Alpha or have you overwritten it in Alpha 16 latest version?

How big is your save-file?

Could you upload your stonehearth.log file after you have this issue? It should be located in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\stonehearth.log

I am playing 64 bit i think.
I made the save in alpha 16.
I cant upload Anything now because i am on my ipad right now i will do that tommorow.

Also i reasently updates my drivers for my grapics card to see if that worked.

1 Like

But it did not work :disappointed:

@Relyss here is the stoneheard.logstonehearth.log (11.0 KB)
also my save is 2,60MB

1 Like

There’s this error in the log:

simulation.core | Loading save | took 1.261 seconds to load
simulation.core | Failed to load: could parse object 2697 of 335801 (size:12313).
client.core | server load save file failed. returning to stonehearth title screen.

Unfortunately, I don’t know if there’s a workaround about it.
Paging @Albert / @not_owen_wilson they might know where does this error come from or if it’s fixable.
(Should the message be “could not parse” instead of “could parse”?) I don’t get why it’s failing.

@Movecraft_Pirates, it shouldn’t do that with any of your saves. This might not do anything, but could you open Steam, right click on Stonehearth, select the local files tab, then click Verify Integrity of Game Cache? It should tell you if any of your game files has been corrupted (not your savefiles, though).

Did you have any mods installed? Sometimes if you add and remove mods and make saves in-between the files won’t load afterwards because they need the mods that were installed when the save was made.

Lastly, if you could zip one of your failing savefile folders and upload it here, it could be useful for the devs.

@relyss Yes i had a mod installed devtools.
And again i wil do the savefile and steam tommorow.

1 Like

@Movecraft_Pirates - The save file should be at least 20 MB, so it looks like it’s not getting fully saved to disk which is causing the load to fail. Are you running on a user account with limited disk space privileges?

Well my game was crashing when i was saving. I lett run for 15 minutes then i closer it because it was stil crashing then i tried to load it

I think that was the cause

i am in alpha 16, 0.16.0 (release 559) x64 build. one of my saves seems corrupt, i try to load it and it gets about half way on the loading bar and it takes me back to the main menu, i dont want to lose it because of the amount of time i have put into it and how far i have gotten (for me). i would love any help i can get

Welcome to the forum, @fluffy :slight_smile:

I moved your post here because it was a similar issue and has more recent answers.

It looks like your save was not correctly saved. Are you using autosave, or did you manually save it?

Can you upload the savefile so that we can take a look? Just zip the folder corresponding to that save and upload it here. In this post there are some instructions on how to upload files if you need them.

Savefiles are usually located in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games

where can i upload it to (6.0 MB)

i think this is the one. this is also one where my workers were working on a building (and a second one later) it got paused on the first and the second they barely started, and they buildings wont be build even if i pause and resume.

Unfortunately that save looks pretty incomplete and won’t be salvageable. Sorry for the bad news.

mine or someone elses

@fluffy - Your save.

ok well thank you for taking a look at it maybe you could use it for something because it has two bugs in it i think.

i have another world that is messed up and was wondering if you could look at it.