Game eats my 16GB Ram + i5-4670 3.40Ghz

I was playing the game and minimized it, then after reopening it, I saw on my Desktop (I have a tool there that shows my CPU etc., what ever). All 8 Cores where diying and my CPU went to 98%, same with my Ram. Now im not able to open my game again. I have a screenshot.
But: ‘new users can not upload attachments’.

If you upload it to Imgur or similar that’ll work for the screenshot too :slight_smile: .

In the mean time… hmm. Smells like a memory leak or somesuch to me.

1 Like

hey there @GodnessCookie … welcome aboard! :smile:

could you provide us with your GPU as well? and feel free to link to a screenshot hosted on something like, and one of the moderators can embed the image directly for you…

here the picture.
My GPU is: NVIDIA GeForce GTX 760 4096 MB
EDIT: Thanks for the fast reply btw, sorry :smile:

thanks… something wonky with the Goblin AI?

have you tried running in full screen mode?

It happend in fullscreen when I minimized it. I used window mode to see what my CPU and Ram is doing.

In terms of the errors, it seems to be two ones repeated an awful lot:

std : : exception: 'invalid file path '/Stonehearth/data/rigs/monsters/goblin/effects/work.json'.'


Remember that if you click on one of the error messages in the red error window it’ll bring up more detailed stuff about that error.

Regardless, I’d say it looks like said error caused a loop, hence the enormous amount of CPU cycles being used.

I somewhat doubt that Stonehearth is capable of using more than three cores at 100% (unless CEF does some really odd things) and I know that it’s unsable to use more than 3GB of RAM, being a 32bit application. It sounds like there’s something else wrong with your machine.

I have that same card! :smile:

Still. Anybody thinks that a rig effect for goblins->WORK is too strange?

Are you using any mods?

(And sorry if it’s a new element in r188 and I’m wrong, I haven’t taken a look through the files yet… it could be related to Alpha 8)

Definitely looks like an infinite loop. :confused: no wonder why it’s eating your system.

Im not using any mod.#
And I dont think its my computer.

Yes, of course, we don’t mean it’s your computer. Something happened in the game, that was cluttering your system. We’re just trying to reach the origin of the problem, and for that we need the more details the better. That’s why my silly questions.

So, when you tried to maximize the game again, you saw the errors of your screenshot, right?

It looks like some activity that was happening in the game when you weren’t looking triggered the error. By the screenshot, it’s like a component was trying to reach the file work.json inside Stonehearth/data/rigs/monsters/goblin/effects, and it didn’t found it, but kept searching for it because it was inside a loop.

In my opinion, that file doesn’t exists (at least in r183), so I understand why the game didn’t found it. The problem is why the game tried to reach that file with that path.

Important question that I forgot :expressionless: :
which release are you playing?

1 Like

Okay, I’ll try to say all that happend. I was looking on my second monitor, while the game was minimized in fullscreen on the other monitor. Then I repopend it 2-3 times. Then this error came up, in fullscreen (it came up after 10 seconds). The game was in fast mode (2x). I’m using the latest build r188. It only happens in this one world. I can make a new game or open other games. If u need something else I hope I can answer.

1 Like