Game crashes, Hearthling stuck in oblivion


#61

If ACE is installed but not enabled, then I’m not sure how it can be an ACE issue because no ACE code is running. It may be an issue with the way Radiant integrated ACE into the game, but I don’t think it’s anything related to the content of the mod itself.


#62

That may be very possible too, Paul. The integration, when it is installed, may be to blame.


#63

I had the same issue again
My base wasn’t closed off this time. It just happens when I have more than 20 people
the game suddenly become very laggy.
And it eventually happened.
I even had all my stuff stored in boxes so random junk wasn’t the issue.
and Yes it was the Ipf that was skyrocketing to 90%


#64

Hi guys,

Seems like I have a similar issue.
After some time the FPS starts dropping down and the game pause itself, but I am still able to move around the camera and open/close some windows.
RAM starts rising up. (memory leak?)

Is there any solution?
Or rather, what causes this bug?

Save here: 1546452192269 | Files.fm.

Thanks in advance!


#65

@Relyss The issue can be replicated by having more than 5(sometimes just 4) patrolling hearthlings under the same patrol group, and they walk around chests/storage containers. You can almost visibly see the moment it happens as the patrol party will start to randomly flip between spots and one disappears. From a visual standpoint, it seems to be a physics issue. Coding wise, I’m not too sure. The log won’t always say what caused the game to crash, but when it does, it says a specific hearthling is throwing a critical error.
When this does happen, if you were to click on the hearthling’s name in the Citizen tab, your screen will go completely black and unresponsive. Their ‘current process’ is Idle or it will just be completely blank. The lag meter will be prominently Yellow.


#66

The temp solution is to check your stonehearth.log file (after a crash) in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth and look for the Hearthling(s) that are throwing errors and copy the number next to their name (ie. 821829 Lee Crowly). Load Stonehearth back up to that Save file. Pause the game.

Press CTRL+C to open up console and type the following (replace my number with your problematic Hearthling’s ‘Asset ID’):
teleport 821829

Press Enter afterwards and unpause the game so that the Hearthling teleports. After they do, please Save the game as a New Save. If it happens again, go back to that New Save.

A possible issue is having too many bowmen/footmen/clerics in the same Patrolling Group. You can access these groups by clicking the Sword icon at the bottom. If all of your patrols are under the same flag (Red by default), please split them up into all 4 flags. Try to keep max 3 per group as 4 and 5 (or more) will possibly cause this.


#67

Nikia, I love you. :heart:

Thank you very much.

“renderer.mob | mob: current position for object 2121479 became NaN. Skipping render mob’s Move() update.”
So, “object” 2121479 was my bravest soldier being stuck.
Thank you for saving him from the Oblivion.


#68

Omg thank you!!! I did something and it worked! Now the yellow thing (ipf) is on 0,6% thx<3!


#69

Thank you, it worked!
But I have another question, can you find a mail that is from me. I sent for about 2-3 weeks ago. It’s about achievements, can u read it and?

Read my mail before u read this

I got the Geomancer on a save now so you don’t have to answer that!

:heart:


#70

oooh, nvm it came back…
it still freezes


#71

Do you have another combat unit stuck again in oblivion? There was some other user in this thread that got it to happen several times after fixing it :slightly_frowning_face:


#72

2 posts were merged into an existing topic: Hearthlings and storage (with save game)