Finery Mod v5.6 Jul 22 [A24+] - On Steam Workshop


#102

Small update to v5.4 to allow for the proper translation of the recipe categories. Thanks to @dalabo for pointing it out and translating my mod!


#103

Hi. I’ve been using the steam workshop version since it became possible. I have noticed that my hearthlings can’t pick up the furniture (in this case simple juniper chair and small juniper tables). First I misplaced them in a ready building and thought to fix the positioning. Well it got attached to building’s blueprint so I had them move the furniture outside and pick them up if they’d place them down again on the -now- blueprints. They don’t pick them up anymore. Do you have any idea why’s that?
Is a building floor an entity?


#104

I’m afraid I do not follow. Are you saying that they moved the chair and table out of the completed building but now will not put them back into the building?

I have noticed that when the game gets laggy the hearthlings will not move items and even will go as far as to put another item from storage to where you wanted an item moved but never move the original. If this is the case typically I just end up undeploying the item. If this is not the case please explain the issue again and maybe add a screenshot. Lastly are you using the new building editor?


#105

I managed to work around my first problem and I am sorry for explaining it so weirdly.
To put it simple; my hearthlings cannot pick up juniper chairs or anything else in the mod. I also noticed it happening to a stone chest which is not a part of it so I think the problem might lay elsewhere. Perhaps in the storage mod I am using.
Thanks for answering.


#106

I’ve been playing my last couple playthroughs with this, and I really like it! One suggestion - you should try making the pavers increase speed like roads do. You can do this by adding something like this to their components:

      "movement_modifier_shape": {
         "modifier": 0.2,
         "nav_preference_modifier": 0.2
      }

Though I don’t think the Cunning banner bonus will apply to these automatically.


#107

Thanks @max99x. It was definitely a thought I just wasn’t sure how or if I should as there is already a buff on the roads themselves. I assume as it is a modifier it would be added to the road if it were placed on top of it? I will definitely play around with it.

Not sure I have even played the Cunning banner :frowning: as usually I go for the military as it is a great way to level up and get gear and loot in hard mode,


#108

Was going to ask but didn’t want to sidetrack the stream but the modifier doesn’t seem to work. I thought it might be to it not actually being a mod or have a navmesh but neither of those items appeared to change anything about the pavers. Thoughts? I even through in a region for the navmesh. And yes I bumped it up way high just to be sure it was actually working. Do I actually need to put this in the ghost…hum…let me try that.

{
   "type": "entity",
   "mixins": "file(clay_old_paver_ghost.json)",
   "components": {
      "stonehearth:entity_forms": {
         "iconic_form": "file(clay_old_paver_iconic.json)",
         "ghost_form": "file(clay_old_paver_ghost.json)",
         "placeable_on_ground": true
      },
      "destination": {
         "region": [
            {
               "min": { "x": 0, "y": 0, "z": 0 },
               "max": { "x": 1, "y": 0.1, "z": 1 }
             }
         ]
      },
      "movement_modifier_shape": {
         "modifier": 0.8,
         "nav_preference_modifier": 0.8,
         "region": [
            {
               "min": { "x": 0, "y": 0, "z": 0 },
               "max": { "x": 1, "y": 1, "z": 1 }
            }
         ]
      }
   },

#109

i have some problems with edgers they refuse to put them on my buildings and they make these stranger ladders. Tried on two different houses with same results :confused:

they are suppose to be ontop of the wall

made a few blocks with edger next to it and they cant figure it out :smiley: poor hearthlings :frowning:


#110

LOL. So are you putting the edgers on top of the house? It might be due to them not being construction pieces. I will have to fiddle with them when I get the chance. Unfortunately life has been really busy but I hope to have some time in the week to play with these.


#111

hahaha @Banto ´s creativity is challenging the @stonemonkey ! :heartpulse: :jubilant: :fire:


#112

Take your time buddy just thought i let you know :smiley: i had problems with them even if i placed them directly on ground also with the new builder as the last picture showed. You can see a little edger left of the 4x3 blocks. builder can’t figure that one out with edger added


#113

Does it uses fractional hitboxes? Like 0.5x0.5x1. The new builder can’t handle those :frowning: Assuming that is your case, you would need to round then to whole number.


#114

Uh oh…is that all region and mob data? Cause that is going to be a pain.


#115

Only region_collision_shape and destination.


#116

Oh good so just in the main json. That should be easier as I don’t think they have any collision. Thanks as always @BrunoSupremo


#117

Can’t wait to find more creative ways to use them once solved :smiley: :heart:


#118

Small update to allow the edgers and pavers to work with the new builder. Thanks to @Banto for finding the issue and @BrunoSupremo as always for helping identify the issue which was both use of fraction/decimal values and what appears to be a deprecated destination handle. These have been converted to the region_collision_shape but in poking around it appears that there are other methods that should be updated so please let me know if you see any odd behaviors.


#119

Hey @stonemonkey , I don’t mean to bother you, but I seem to be having an odd issue with your trophies that are placed on the wall, such as the bow and Kobold… hats? I can only place them on 2 walls when in the new builder, and they dont appear at all on the other two walls. I will post screenshots if it helps but its just going to look like an empty cursor pointing at a wall :sweat_smile:. Also, I use many mods so I suppose there could be a conflict but I don’t know which would/is causing it as they are just new entities right?


#120

So hanging stuff on the walls has always been a problem. Please post screen shots but I will also try and reproduce.


#121

Finally had a free bit of time to actually see and it seems that some of the methods that were used in the past to place items on walls has changed. I am looking at it now. Similarly it seems there are some weird adjacency issues which may be related to the wall issue.