Faster building > than 5 block at a time


#1

you know how before the Hearthlings would place one block at a time and now they place 5 at a time when building
Is there a way to increase that number?
to like 10 or like 20?
or maybe even 1,000,000! LOL! instant build!
I am not very patient.
if so where is the file located?
which one of the creators would know about this mechanic so I can tag them and they could give me an answer?
@BrunoSupremo @Relyss


With Release 806 the mods tab is gone
#2

Hearthlings inventory limit and material distribution for building is a key for this question. Increase a backpack size.


#3

maybe, but I think even a normal hearthlings backpack holds enough material for far more than 5 blocks. That being said if you raise that value too much, they use up their inventory in a single action.


#4

so change this
image
from 4 to 9 to get 10 blocks placed at a time?


#5

A single wood item corresponds to 60 building voxels, (other materials have different ratios) more or less it will “hammer” the building 12 times before getting a new item in his backpack. So if a hearthling have more items in his backpack, he will just build it for longer before needing to search for more items, but it will still place 5 voxels at a time.


At /data/constants.json you can change this:

{
	...
	"constants": {
		...
		"construction": {
			...
			"MAX_DEFAULT_MULTI_BLOCK_DISTANCE": 2,
			...
		},
		...
	}
}

to something like 100. It controls the range a hearthling has, so the 5 blocks he places are always all around him. You need to change this first, cause even if you increase the placeable blocks to 9000, it will not consider those outside their range.

Then at your user_settings.json add this:

{
	...
	"mods" : {
		...
		"stonehearth" : {
			...
			"teardown_num_blocks" : 9000,
			...
		},
		...
	},
	...
}

#6

I increased the values 4x but it doesn’t seem to make much difference they only place 5 blocks at a time
ConstructionMod.smod (7.8 KB)
“INCREASED_CONSTRUCTION_RATE_FABRICATE_NUM_BLOCKS”: 20,
“INCREASED_CONSTRUCTION_RATE_TEARDOWN_NUM_BLOCKS”: 32,
“MAX_DEFAULT_MULTI_BLOCK_DISTANCE”: 8,
“MAX_SCAFFOLDING_MULTI_BLOCK_DISTANCE”: 16
what am I doing wrong?
@BrunoSupremo
is there another file I need to edit?


#7

Did you change the user_settings?


#8

I thought

was

but now I’m thinking otherwise.

where is that file located? I didn’t see it in Stonehearth\mods\stonehearth.zip\stonehearth\data


#9

user_settings is a file in the game folder (not in the mod) that saves a lot of your settings, like audio, max hearthlings, etc


#10

image
like this? @BrunoSupremo


#11

@Kodi4444 have you made any progress on the .smod? I get it to work just fine if I put the settings in the user_settings.json, however I can’t seem to get the actual .smod to work. I was getting the same error messages you were, that you posted in another thread. (I am by no means an expert on this, just usually a casual observer who likes to tinker)


#12

It worked before the update but now it doesn’t work.


#13

Ok thank you


#14

it doesn’t work in the latest version. What will I have to do to make it work in the latest version? @BrunoSupremo