Farmers and Cook not doing they're job

Farmers won’t harvest crops after growing them. Instead of farming, they’re placing items. Cook doesn’t help harvesting crops or planting crops too. Please fix.

Steps to reproduce:

  1. Workers promoted to farmers.
  2. Farmers plant crops.
  3. Farmers doesn’t harvest crops but instead placing items.

Expected Results:
Farmers and Cook doing they’re job.

Actual Results:
Farmers and Cook placing items that are mined.

I tried to promote another farmer but it doesn’t help either. Started a new game and the same thing happen.


Version Number and Mods in use:
Alpha 17 (release 610)

System Information:

Have you tried turning the haul checkbox on your farmers off?

1 Like

tried. they just stand there and won’t move at all. but once i checked it back it seems that they’re working just like how they’re supposed to for now. hope nothing goes wrong. thanks! :slight_smile:

Have you hit the town inventory cap? I believe farmers stop farming after you’ve hit the cap.

I’m getting this problem too. Nowhere near the inventory cap, same thing. Farmers stop harvesting, start hauling. Except when I unchecked hauling they idled, and when I rechecked it they went back to hauling ore.

It seemed to happen sometime between promoting a cook and promoting a shepherd, but also hit around when I started planting multiple cornfields. Oddly enough, they readily harvested turnips, but ignored everything else.

1 Like

If you’re on last night’s latest build on Steam unstable, farmers may have issues with farming after load. Yang has a fix coming later today :slight_smile:

Yes i have the same problem with that build, so now waiting for the update.
So no gaming for now :cry:

Until the fix is live, I had this problem but found that removing the old farms and replacing them works just fine.

The fix it up, problem solved

1 Like

I have a different but related problem, my cook won’t do cooking chores as long as there are fields to tend to…

Welcome to the forum, @Bahriel :slight_smile:

Are you sure that the cook has enough ingredients for the queued food and can path to them?
Have you tried unchecking ‘Haul’ for the cook to see if that helps?

Maybe you can upload a savefile so we can take a look.

I found a solution, of course that brought to light another issue, disappearing goods.
I was still waiting for the cook to create their workstation, and i had 2 stone ready for it… apparantly that stone was either reserved by someone else, but not yet in use, or just not there, cause the moment i chucked open a stonepile, the cook set to work.

1 Like

I see. Yep, I’ve seen similar reports about resources that seem to be reserved by more than one people and then no one actually using them. And we’ve been tracking the bugs about disappearing items, hopefully fixed with the last builds.

Thanks for reporting anyway! :slight_smile: