Everyone Idle After Loading Game


#1

Seems like everyone just stopped doing what they were supposed to after loading the game. There is a scaffolding that hasn’t been taken down, and they weren’t engaging with it. This, alongside of workers not collecting any resources that I had indicated that they should. I tried to remedy this by waiting until the workers needed to eat, to see if that fixed it, which it sadly didn’t. Making someone a trapper or a farmer did not help either.

Here’s a screenshot which occurred right after loading:


#2

saving/loading is expected to be fairly buggy at this point… but in the interest of thoroughness, is there any information you can provide to flesh out this format? :smiley:

Title:

Summary:

Steps to reproduce:
1)
2)
3)

Expected Results:

Actual Results:

Notes:

Attachments:

Versions and Mods:

System Information:


#3

I thought I’d be useless! So let me fill some of this for you:

Steps to reproduce:

  1. Save game during a time in which a room is yet to be completed, along with a farmer’s hoe and a sword queued up.
  2. Load up. All went well, except a little glitch where all I saw was sky for a few seconds, after which if I scrolled, all went back to normal.
  3. First thing I get is this goliath of an error report;
  4. Everyone just stood there, leaving me riddled with tears in my eyes.

Expected result: Load up and continue playing!
Actual result: Disappointment. Well, everyone just stood around and did nothing.

Version is 0.1.0, no mods.

I’m running a Win 7 on a pathetically old machine.


#4

Yes, this is like this other bug, the same errors, but with direct conclusions. Loading will be a continuous effort, it seems.


#5

Yup, you are right! I certainly did seemed to have spawned inside the ground. Then again, I wonder if the idle workers are a result of this, or rather just where the working queue just isn’t transferred properly?


#6

No, I loaded the game several times but had no ongoing working queue for the carpenter.


#7

Today, my settlers were able to recover after loading.

I was trying my mods, to see if they were broken (apparently they’re not, as they mostly override models). I began a new game with one of my mods, everything went well, I saved. I closed the game, waited for the sky to disappear and load my terrain, and when I saw after a bit that my settlers were hungry, I ordered to harvest a berry bush.

The one who was nearest rapidly went to do it, and automatically took a plate and ate. Then, when he was eating, a second one went to take another plate and ate. Then, another one. They take some seconds to react and go, as if only one person could be involved with the basket at a time. I gave them some more orders, and they fulfilled them.

I put in practice a horrible idea, change the mod to my another mod and loading, to see what happens, as the mods override the same objects. The result was that one kind of tree showed the vanilla version, and the rest were invisible and intangible.The terrain colors and the berry bushes were overridden correctly.
I thought of trapping some rabbits, in that desolate place, but after harvesting the second one the trapper got fused with the remains :sweat: At least she idled and moved, but didn’t respond to my commands and some errors popped up.


The Modding Requests