[Develop 2534] Auto Interior Wall error

8/12/2015 UPDATE: It turns out it’s not the stairs it’s causing the problem. We discovered it was the interior walls that’s causing this engine error.

Old message below
Could of been clever to do it…Didn’t worked as expected.

When I tried to make a makeshift stairs out of manual block placement (the one that looks like a tetris) and auto-build walls after that, I get a scripting error.

The stairs was at least 7 blocks high, enough to match the height of walls + second floor. I just wanted to see if I could build an inn. You know…hotel? With lots of beds, and stairs…that I tried to build?

Sigh. So do I really have to wait for 3 months for the devs to build a real stairs feature?

Here’s four screenshots of this occurrence.


you gotta build the stairs after you make the building; should work then :+1:

edit: looked again and i’m pretty sure it’s the walls giving you problems (can’t build interior walls)

well, you can build interior walls, but it’s a very, very finicky process, and in the end you’re best off just avoiding building interior walls. and yea, I agree, it’s most likely the interior walls you have there.

EDIT: from what I can see from the screenshots, the error has something to do with the wall that you tried to build in that 2nd room. see the back wall that should have been there? it’s not there. probably because of how you set the rooms. what likely happened is it tried building too many walls in the same place at once, causing the engine to break down. every wall except that back wall managed to build perfectly find, and that back wall is what sprung the error, failing to build.

to avoid it: just don’t make interior walls. if you want to make separate rooms, you can, but you’ll need to make each floor one by one, and after the floors are build, THEN you make the walls. I’m not sure if the “wall” tool will work on the inside, so to be safe, you’ll have to build the walls out of the slab tool, leaving enough space to place the doors.

…Wait so it’s the interior walls that’s causing the problem? I guess I should add it to the to the title.

y̶e̶s̶ ̶y̶o̶u̶ ̶c̶a̶n̶.̶ ̶g̶o̶ ̶t̶o̶ ̶t̶h̶e̶ ̶v̶e̶r̶y̶ ̶t̶o̶p̶,̶ ̶y̶o̶u̶ ̶s̶h̶o̶u̶l̶d̶ ̶s̶e̶e̶ ̶a̶ ̶p̶e̶n̶ ̶n̶e̶x̶t̶ ̶t̶o̶ ̶t̶h̶e̶ ̶t̶i̶t̶l̶e̶.̶ ̶c̶l̶i̶c̶k̶ ̶t̶h̶a̶t̶.̶ ̶t̶h̶a̶t̶ ̶w̶i̶l̶l̶ ̶a̶l̶l̶o̶w̶ ̶y̶o̶u̶ ̶t̶o̶ ̶c̶h̶a̶n̶g̶e̶ ̶t̶h̶e̶ ̶t̶i̶t̶l̶e̶,̶ ̶m̶o̶d̶i̶f̶y̶ ̶t̶h̶e̶ ̶s̶u̶b̶j̶e̶c̶t̶ ̶t̶y̶p̶e̶,̶ ̶e̶t̶c̶ oh of course you edit the title and your comment after I type this lol

also, we’re not entirely certain WHAT is causing the problem. we just know that interior walls cause problemS. of which this MAY be one of. it’s entirely likely.

Must have typed it in while I was editing. Heh.

What I was trying to build is an inn-type building. Never thought this error might come up because of the automatic interior wall-building.

it’s still possible to use interior walls, but you will need to hold your hearthlings hands and do it step by step. first the floor, then this wall, then that wall…