Cyclic game crashes

resolved

#1

I’m running the latest official release of SH Alpha. The game loads up perfectly fine, but then after about 20 seconds of game play (No matter what I do) the program stops responding and crashes.

I get no error messages or anything, it just goes down.

It might also be worth noting that I tried entering the menu once the map loaded to see if that made a difference, but even in the game menu it crashes after about 20 seconds.

Anyone have any insight on how to solve this?


#2

Hey @LordNevs, have you tried updating your graphics card? Make sure you check your Cards website for the latest, sometimes the auto updater/checker doesn’t actually grab the newest one.


#3

It’s updated.

(This is here to meet the chat limit)


#4

Alright, if you’ve already checked your card’s website, could you provide us with your system specs?


#5

I built this desktop, so no I cant contact anyone for support.

GPU: Radeon HD 7870 (2GB) (1100MHZ)
CPU: Intel i5 3470k (3.2GHZ)
RAM: RIPJAWZ Gskill (4GBx2) (1600MHZ)
HDD: 2x Western Digital Caviar Black (2TB)

Pretty sure nothing else would contribute to the issue. If you disagree, I can go more in-depth.


#6

Well, your system is fine, and your graphics card is up to date… the last thing I can think of off the top of my head is what operating system you’re running?


#7

the card is telling you its updated? or you have tried to manually update it too?

i think we’ve had cases where folks were certain they had the latest drivers, only to discover there was indeed an available update hiding amongst the internet weeds… :smile:


#8

I always do my driver updates manually. Windows can never seem to find the most recent ones. Especially with some of the older cards.

I am running the latest version of Windows 8, that most likely has nothing to do with it.


#9

Most likely not, though I have seen some issues with people using 8.1… mostly it’s Vista that causes issues. Which isn’t surprising.

That’s the extent of the basic stuff to check that I can think of. if @Teleros has nothing to add…

Paging @not_owen_wilson


#10

Can’t think of anything else :frowning: .


#11

Next step: Send us (via PM etc) your user id (you can find it in the ESC menu or in your user settings file) and we’ll try to correlate it with a crash in the database. Also, check if there’s anything in your stonehearth.log file?


#12

Whelp, I had another Radeon HD 7870 in my office and I swapped the two cards out. Oddly enough that fixed it.

Neither cards have ever had any issues before. This is the first time i have seen a single application that didn’t work with a card non-specific to it’s model.

But at least it’s working now.


#13

You win the weirdest fix so far award. :slight_smile: glad it’s working


#14

Tagged as resolved, but… Swapping with another identical card as a workaround suggests that the first card had something weird. :confused:
Or maybe wasn’t properly recognized, and unplugging-plugging worked.