Custom building don't get finished

Building material gets used up before the building is completed

Steps to reproduce:

  1. Build something with slabs (4+ block)
  2. Watch them build
  3. See them not finishing the building

Expected Results:
A completed building

Actual Results:
An uncompleted building

As you can see in the picture, the building is incomplete and the building material is used up but i still have more in the stockpile.

Screenshot (1)

Version Number and Mods in use:
Version: 22.5

Better stockpiles
Smart crafter
Minecart and rail
MaraRose’s container mod
Unit frame activity mod

System Information:
Intel i7, 12GB RAM, Nvidia 970

I can’t test this right now, so I can’t say this for sure, but it appears to me that the Hearthlings might not have enough room to place the upper half of the walls. If you dig up 2 or 3 blocks, that should hopefully work. (By digging up, I mean digging down from the surface to a point where the pit merges with your tunnel, because Hearthlings can’t move up :stuck_out_tongue: My point is that you need more space.)

1 Like

Yeah you cannot build walls which are as high as the tunnel walls but you can cheat with console and the instant build command.

will you guys(girls :slight_smile: ) change this with the new building tool?

1 Like

If they can mine 4 blocks tall with no climbing/scaffolding then why not build 4 blocks tall with no climbing/scaffolding? guess i have to do it some other way then.

It could also be that they don’t reach the 3 corners which are “locked” behind surrounding blocks.
Not sure though; I’ve never tried to build something with walls that are directly surrounded by other walls.

I tried to build the corners first but same thing.

Yes, Chris says there will be a fix! :blush: