Crafting workshop bug ( save included)

fomr what I have noticed this seems to be with every type.

I undeployed all my workshops to move them so I could place more stockpiles and once I placed them back it seems to have broken all the ques. its saying that I don’t have the needed workshops

I have tried to promote my crafters to workers then back to thire crafter jobs.
tried to move the workbenches a few times
tried to create new ones, place them and destroy the old ones
tried to save/load
tried completely exiting the game then starting it again

the save with the bug:

the save that seems fine 2 in game days beforehand:

@8BitCrab and @jomaxro

seen or heard about this one? and im not sure who to page form TR


nope, this ones new for me, thanks for the report :smile:

[quote=“Fralee, post:1, topic:19424”]
and im not sure who to page form TR
[/quote]i’ll page @yshan for this, but it is the weekend so she probably wont see this until monday.

btw, which dev build is this on?


the most current one. been keeping it up to date to test things out and report bugs :grin:

just a note, during the unstable that can be very vague, but i’m guessing you mean 2807.

1 Like

:open_mouth: uhh good point :sweat_smile:

yes im on 2807 curently


the save before the one that the bug happened to its fine.

ill upload that one too and test it a bit more

Can confirm this on 2807. I ran into this tonight too, when replacing fallen crafters with new hearthlings.


Hi there,
The “save with the bug” link in the original post doesn’t have a server_state.bin file inside it so I can’t load it. :frowning:


@yshan: fixed I hope =]
I reloaded that save folder and posted a new link

Hi. Taking a look. Also wanted to drop by to say that your saves have been very useful in finding ways to optimize some of our pathfinding and job scheduling. If anyone else has really really big saves, I’d love to take a look at them too and see what I can do. Thanks!


As requested! (8.4 MB)

That should have both a crafting workshop issue (Potter’s Kiln, crafted by the current (and only) Potter). Also of note, the potter gained ~200 XP per item crafted, which allowed him to reach level 4 after only 5-10 items!


just glad they were useful to you and the team @Ponder :grin:


@Fralee, all week he’s been loading your saves and swearing in admiration. :wink:

I will make a new thread specifically for giant saves with perf issues.


I loaded the save and it seems like everything looks normal … It says there is a kiln, but the items in queue cannot be crafted because there’s no clay and for one of the items, it cannot be crafted because the potter is not level 6.
Is there something specific I need to look for/do?

@yshan, It’s been a while, but if I recall correctly there was clay (it ran out) and the items were skipped in the queue until all the clay was used making vases. Additionally (no idea if there is any way for you to see this), the potter gained experience at an exorbitant rate. Then again, maybe I was just tired and I am making all this up!

1 Like

I noticed a similar issue but it was with my herbalist O_o

they hit level 5 in 10-15 items

EDIT: Maybe a bug that hits a random person or class?

1 Like