Cook won't build a stone mill grinder


Steps to reproduce:

  1. assign cook to build stone mill grinder

Expected Results:
cook to build item

Actual Results:
cook does not build item, does other work instead, or idles if there is no other work
tried canceling and restarting order, as well as saving and loading game repeatedly to try and correct. Nothing helped

Version Number and Mods in use:

System Information:


Have you tried using the Hearthling therapist to un-assign hauling?
If you are able to upload the save game, the moderators can help determine if there is something else going on behind the scenes. Like pathing issues and such.

I am assuming that there was stone available for the cook to craft this item.

yes to the stone. What is hearthling therapist?

It accessed with your citizens button, the one that tell you how many hearthling you have.

you can assign/unassign them to hauling or whether they are do their job on not. Some times toggling the job check mark will help them get back to work.

edited: as you can see I have 3 of my farmers set not to haul anything.

1 Like

oh yes, I did try that. Thank you thouh

also had this last week. Its happen in larger citys were everybody has something to do (usually cook is trained after 1-2h gameplay). Usually its fixed after a save/load.
This kind of placement issues were pretty common in the last 1-2 month.
IMHO placeing anykind of workbenches should have a very high priority.

Hey there @Ryan_Hickey, welcome to the Discourse.

Just want to double check, when you say “build”, do you mean craft or place? Also, what version of the game are you playing, and do you have any mods installed?