Mason not crafting

I changed my hearthlings job to cook at farmer level 3, and she grabbed the spoon and changed job titles. She even changed outfits to reflect her new job. After changing jobs, I assigned her to make the cauldron and whatnot, but instead she returned to the field to farm. I checked her inventory, nothing but the spoon. I demoted her and changed a separate level 2 farmer to cook, same result. Neither will cook, or even make the cauldron to begin cooking!

  1. Level a farmer to level 2.
  2. Promote to cook.
  3. ??? Still farms.

Alpha 21, 0.21.0 (Release 707) x64 build

Welcome to the forum, @LemonMonstare :slight_smile:

This is not a bug, it is actually intended that the cook helps with the farming duties when he doesn’t have anything to craft.

It’s an extra behavior, just as herbalists can heal besides crafting, and engineers can repair turrets besides crafting.

If she can’t craft the cauldron, verify that she can reach the stones.

1 Like

I verified that she could indeed reach the stone, as my other hearthlings are picking it up to use for other projects. I waited for other projects to complete, and she still farms instead of making the cooking pots. I figured she was farming when she was free to do so, but even when all my hearthlings have nothing to do, she just sits and chats… I’m not sure what’s wrong.

I even made a new stockpile and only allowed stone, my hearthlings moved the stone and yet she still wouldn’t make her pots. My mason uses the stone just fine.

As you can see, stone is behind my cook, everyone is standing around after I asked them to move stone to new location. This is the second time I moved it, in the hopes it would work… Cook is just standing around chatting with other hearthlings instead of making pots and pans and such. ):

Who is assigned to the order in the workshop? Is it her?
Or is the order just “Queued”?

If the cauldron isn’t crafted even after save/reload, please upload the savefile and we will take a look at it. I’m after some bugs about crafters stop crafting and similar.

Going to upload a save file, soon as I figure out how. Here is a photo for now, It was highlighted as green, but then I deleted the queued objects and re-queued them, where now it is not green and she is standing by stone still.

Ah, might be the bug where if the crafter starts to craft but suddenly runs out of ingredients (or the workbench becomes inaccessible), and you delete the order, it’s still pending in the background, and the crafter will refuse to craft anything until that order is cleared.

But it doesn’t make sense here because the only thing she can craft are the workbenches at this stage :thinking:

To upload a savefile:

  1. Find the save folder for the saves you wish to upload. By default, they are located in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install).
  2. Zip the folder.
  3. Right click the folder (should be a long set of numbers).
  4. Left click on Send to in the menu that appears.
  5. Left click on `Compressed (Zipped) folder).
  6. (Optional) Rename the folder to something different than the default set of numbers.
  7. Upload the save.
  8. If the zip is less than 10 MB, you can upload it directly. Either use the upload button or drag and drop it into the compose window,
  9. If larger than 10 MB, upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here. (4.9 MB)

Hopefully that is the right folder. Thank you. (:

1 Like

She should resume crafting after loading the savefile.
Thanks for reporting anyway! :slight_smile:

Wow… I reloaded so many times, saved and reloaded… And it just now works after I upload it. Haha how strange… I promise you I tried that before.

Anyway thank you very much for your prompt replies, I’m sorry.

:slight_smile: I really appreciate your kindness!

No worries! I’ve recently found a weird bug where the crafters stop crafting that was different from other existing “crafter-stops-crafting” bugs. :thinking:

I think it might have been what happened in your case, especially if you say that reloading didn’t work before. I will keep this thread as a reminder for that one, until it gets fixed.

Well now it appears my Mason is going through the issue… How strange. I did the usual steps, I demoted and promoted, I saved, reloaded. I deleted the queues, saved, reloaded, re-queued…

Huh. So here’s my new save file, same town, cook is working, etc, but my mason is not. Maybe it will help you with your quest on that bug? (6.1 MB)

1 Like

Yes! Thank you very much.

Do you remember when exactly did he stop crafting?
Was it when you began building the outer walls, perhaps? Or a while before / after that?

Did you run out of stone at some point? (Either for building, or for crafting)

Edit: @LemonMonstare, if you turn on town alert right after loading that savefile, and turn it off a couple of seconds later, the mason starts to craft everything in the queue correctly.

I’m still waiting for devs to look into the problem.

Sorry, I have been busy with work and life, was not on my computer for a while.
I thank you very much for getting back to me with a fix for that!

I did run out of stone once, a while before that, for the wall I was building. Everything started working again after I dug up some more stone, though… Then the cook/farmer thing happened, and then the mason stopped working. I will load up the save file soon, unfortunately I have little time to spare right now! I will update this thread if it continues with other hearthlings!

1 Like