Cook wont do its job

Summary: Cook wont do its job. It keeps harvesting and tending to the fields instead of making food and crafting the workbenches i tell it to. I have 4 farmers. The cook does not need to tend to the farms…
I dont know if this is a bug or not. But its frustrating as hell that i cant get it to do the cook jobs. So i can make food for my animals.

Steps to reproduce:

  1. 5 Farms
  2. 5 Farmer.
  3. Make 1 a cook.

Expected Results: Cook still tends to farms and wont do cooking jobs and que…

Actual Results: Cook still tends to farms and wont do cooking jobs and que…

Notes: Make so you can disable a job to do other job types. Need more control.


Version Number and Mods in use: release-687 (x64) No mods.

System Information: Win 10

1 Like

simply open the hearthling job window and disable hauling, mining, and building so that specific hearthling only does their job and nothing else. I do this regularly to complete specific tasks faster, or when training a new apprentice so that they gain more experience.

I did that. It still tended the fields as if it was its job.
I also tried to take the job away and reapply it.
I also checked if the spoon was equipted.

okay that is odd

you had the cooking pot and everything placed and accessible as well?

then yeah something goofed up

Stone Cauldron. That was all i managed to do.
Cook refused to make anything after that. First around now the cook suddenly did the job.
But all this annoying waiting…

If the cauldron, mill or oven (required for the recipe you ordered to craft) aren’t placed, he can’t cook.
Did you check if you had enough stone or whatever other material was needed for crafting the mill?
You need the mill for the animal feed.

The cauldron was placed and i did check if i had enough. Yes.

If the cook is still not doing his job after saving and reloading, please upload the savefile and we’ll take a look.

The cook have done it now. But it took several ingame days were he only tended to the fields and would not do the cooking jobs.
I think it could all be avoided if i could ban him from tending fields as he’s job and say only cooking jobs.

I have actually experienced this as well when moving queued orders around, the order list is refreshed and sometimes duplicates the order. this was never fixed I think I mentioned it in a previous bug report. I think it may also be that when it duplicates the order and I delete one of the orders in the list, while the icon is there, the order does not go through.

this may be what caused it I don’t know, I’ll try to repeat the scenario

I checked multiple times if the item were crafted event though it was in the que and it said crafting.
I werent.

It took several ingame days before the cook finaly decided to do its job instead of tending fields.
I dont get why the cook is tending fields though. Its not the cooks job.

yeah, I just checked this

so when I queue an order for my carpenter to make a reinforced wooden door and my iron is used by my blacksmith then the carpenter queue order does not get reset. the carpenter does not try to complete a different order because he already started working on the reinforced wooden door. so I have to remove the order from the queue for the carpenter to work on a different order that only requires wood. then I have to replace the order for the reinforced wooden door again.

There was more than enough recourses in my case for it to build.
I had sooo many recourses that i have a hard time storing it.

Though this is the cook. Not carpender or Blacksmith.

yeah but that is the question, if I suddenly got iron again I’m not sure my order for the reinforced wooden door would complete or not, because the carpenter is stuck in the middle of the crafting process with the iron that was used by the blacksmith.

see what I mean? I’ll have to test this by leaving the order there and mining some iron and seeing if this is resolved or not

Your testing is with lack of recourses though.
I didnt have any lack in recourses.

right but as far as I know this is a bug that may be related. I don’t think the game did this before. if you didn’t have the resources to complete an order the carpenter would just try to craft something else that he does have the resources for.

it may be that you had the resources, but they were not in your stockpile or something like that and still caused this to happen

I had a similar situation with my just promoted weaver. He refused to craft the workbench, although he had everything required. The icon was green in the crafting queue, but the weaver still didn’t do it. After several ingame days I de-promoted him and promoted another Hearthling, who instantly started to craft the workbench (and does a formidable job since).