Blacksmith doesn't do it's job

I honestly don’t know what to do, it won’t do anything at all, and it doesn’t matter which one person I pick, none of them will do anything! I’m already day 28 in and I need a blacksmith bad to defend with better gear, but it never works and the only thing I need is an anvil and the forge but it never is built they just idle or do other worker stuff.

1 Like

Could you ellaborate a bit more about what exactly he is not doing? Perhaps with screenshots?

Have you tried removing the recipes and queueing them up again? Can you show some screenshots?

I will record all of what I am seeing. I have tried queueing them them up and off again, for some reason when I wasn’t looking, he made the anvil but… To make armor I need him level 1 but he does nothing and won’t make the forge… What he is always doing for like a whole day or two always “Restocking items” Picking up items that workers are suppose to do. And when I click off haul he’s always idle then when I click off job and again he goes back to also building a ladder, I don’t know why he is doing this. Also, I just promoted 2 of my farmers at different times to cook, and starting try to make the cook items to need to cook stuff, they just harvest the field always and it’s gotten to the point at stuff I have to survive without a blacksmith, potter and a cook, with my armor only coming from gold chests and some trades and having to spend a whole day going out for a whole day of berries and bigger farms.

Here is the video I did. if you need more I’ll get a lot more.

Do you have any accessible stone? Both things you mention - the forge, and cooking equipment - use stone to craft.

I know the video shows 20 stone is ‘owned’, but as far as I could tell there wasn’t any in that central omni-stockpile (just lots of ore). If that is sitting some place your hearthlings can’t get to (some ledge somewhere, or in a walled off region, or something), that’d explain the blacksmith - tries to craft it, can’t acquire the ingredients, goes on to other tasks, waiting for the ingredients to become available.


That was the problem thanks! Now I can get a blacksmith,

Also, you seem to be on build 559, that was a LOOONG time ago.