Construction won't finish

I’m trying to build a wall on my perimeter to keep out those bad guys. I was able to start it and get a decent amount done, but now my works won’t make any progress.

I was thinking that maybe the fact that the roof was slightly inside the neightboring land that was causing this issue, but I’ve tried digging it all up, and they still won’t work on the wall. I have a save of remove the nearby land as well.

Steps to reproduce:

  1. Load my save from “won’t”.
  2. Try running the game to see if they’ll build the wall structure (seen in the save’s screenshot).

Expected Results:
Structure should be constructed by citizens who can build.

Actual Results:
No one works on structure.


won’t (6.8 MB)
I tried zipping my safe folder, but it was over 10MB, which is over the site’s attachment limit. So I put it in a .rar, but that wasn’t allowed, so I zipped the .rar file. I hope that’s not an issue, apologies for any confusion.

Version Number and Mods in use:
Alpha 17 on steam, “Current Content BuildID: 1224500”

System Information:
Windows 10 Pro, AMD FX-8380 4.01GHz 64 bit, 16GB of RAM.

3 posts were merged into an existing topic: [A16/A17] The buildings my hearthlings will not build (round 2!)