Cannot finish wall


Well im playing the game on hard to see how long im going to survive , the thing is to funnel the attacks that i recieve whitch are a lot (just like i like it from hard mode) , i tried to build a wall around my city (no conection to any political candidate) and it partially works , the thing is my guys dont finish building it , they just left it with the stairs and didnt place the doors that would make the “entrances” or anything soo i basicly have a climbable wall to protect me witch is kind of problematic , and they for some reason recognize the wall as unfinished and not buildable at the same time…

Steps to reproduce:

  1. Build a single line wall around a large area (maybe is related to the fact that i used the wall tool)
  2. Place doors to mark the entrances for those points

Expected Results:

Build the wall and funnel attacks to improve safety.

Actual Results:

Wall isnt finished and it just dosent work.

Number: c359fa84-2ce0-11e6-a8af-e8de27a72504


Steam Community :: Screenshot :: 2 - “usefull” wall
Steam Community :: Screenshot :: 1 - never finishing wall

Version Number and Mods in use:
Current with no mods

a18 dev? or a17 stable?

a18 dev has a new number of problems which prevented even building designs that were 100% OK in a17 from completing, though obscure voodoo workarounds may exists from repeated testing from a save game before the problematic part is built.

1 Like

Im on 17 stable currently.

a few things to try (well, may not work, but won’t make it worse i guess)

  1. save game to new slot. exit the game. reload the save to see if construction continues. There are many times where a reload will “fix” things.

  2. reload from earlier game before you start building and try again. with the following (not sure which works exactly, but I managed to avoid all building problems following them):

    • avoid merging placed templates (editing any structure touching more than 1 placed template will ‘merge’ it). Avoid “overlapping” templates.
    • save before any actual building. do not overwrite this save until the building actually completes (can save to new slots though)
    • build templates one by one. Or at least, try to avoid building touching templates at the same time.
    • avoid complicated furniture placements (not sure whether this as any effects, but I’ve seen at least one case where a prematurely placed furniture block access to scaffolding/ladder which are not taken down. could be freak though).
    • avoid complicated building design, or at least consider breaking them into several stages of simpler construction.

there are probably more advice other veterans can give you. I only started at a17 :wink:

good luck!

1 Like

Im going to try that and i wll report back =D

Hmmm. A couple of questions:

  • Do you have enough material to complete the wall? Looks like a lot of wood and stone!
  • Your hearthlings need to be able to reach the wall (pathfinding) to build it – if they’re enclosed within your settlement and can’t see a path to go build, they won’t build. (For large walls, it’s usually best to construct them in increments rather than placing one giant wall all at once.)
  • Related to the above – did you place doors in the design phase before starting building? (It’s difficult to tell from your screenshots; I didn’t see doors in the walls there…)

Most usually, if hearthlings are not building, the overwhelming reasons are that they don’t have the materials they need; the can’t pathfind to the needed construction; or they are tending to other priorities that are higher than building. One way to test this latter one is to set your hearthlings only to Build in the citizen’s menu. If they’re still not building, then one of the other two is probably the culprit.

If you’re still having this issue after testing out these things, please send us a link to your save and we’ll take a look.

1 Like

Yeah i am on 18 and cant get the simplest of buildings to complete…even the templates. Doors arent placed and scaffolding is left up

Thanks for everyone for helping

Soo i tried to go back a couple days an remake the wall and it worked.

I think the issue was that i made a single line wall and used the “wall tool” not the “free standing wall” that may have caused my workers to build a double wall on one space.
That might be the reason why even trough i forced them to build a door they couldn’t cross it.

It might be something like that.
Either way i builded it again and now it works.