[Con] No doors/windows are build into building

Building never finished, can’t place doors/windows/lights

workers start building in a normal way. But the building never gets finished. At the point where doors, windows and lights are to be placed the workers stop working on the building. The workers still do other stuff like harvesting etc.

Steps to reproduce:

  1. I started new games to see if it happens all the time, and it did. In every game the workers stop building when its time to make the doors etc.

  2. I made doors and windows with the carpenter so they could be used in the house but the workers won’t use them. I also tried to put the door I made with the carpenter into the house like you would place any other item so it can be used, but it won’t be placed.

Expected Results:
my building would be finished with working doors so my settlers can live inside a house

can’t attach any screenshots yet since this is my first post…

Versions and Mods:
alpha 4, no mods

System Information:
OS: windows 8
Processor: 4e generatie Intel® Core™ i7-4700MQ
8,192 (4,096 + 4,096) MB
Graphics card: NVIDIA® GeForce® GT 740M


I’m fairly certain you need to put the windows and doors in place manually by clicking on them like regular items. From what I see the building editor just makes the places where the items are suppose to go.

1 Like

No I’ve found they place them automatically, so it’s definitely a bug…

1 Like

Maybe I wasn’t clear enough in my first post so here’s some more information:

during the creation process of the house I manually choose what size I want, which walls etc, and where the door and windows should be placed. This works fine so I tell my worksers to build the building. Then they start building but eventually when (I think) the building is almost finished the stop working on the building and there are holes in the wall where the door/windos should be, also the scaffolding (i hope it’s the good word) is visible around the house where the windows and doors should be build.

If there are any questions I can try to explain more, I’m not used to make bug reports so I don’t know what to look for

Sounds like he is having the same issue as me

The little blighters never finish of the last part despite the parts being available. Unable to use the building as the scaffolding is never taken down

If you place the parts manually during the build phase, they leave the scaffolding in place

Also, alt tabbing out and back in the game caused this UI corruption :blush: But you can see the scaffolding nearly torn down, but the last bit never goes away.


I’ve had this same issue, also with the scaffolding being nearly but not entirely torn down by the end. Did not have the same UI corruption issue, but all the rest of it is familiar to me. Perhaps I just didn’t Alt+Tab out.

I think the scaffolding has something to do with placing doors in the building designer. I made a building without a door and had no problem with the the scaffolding being removed.

1 Like

I agree, because in my case they also did not place the doors or windows or lanterns, which was all that remained to be done on the building. That, and the tearing down of the scaffolding. Doesn’t seem like it would be two separate issues.

But actually, you probably need to manually make the doors and windows with your carpenter, don’t you? I didn’t do that, or rather, I hadn’t done that when I got to the thing where the scaffolding was not torn down. I meant to, but I had that other thing where my carpenter couldn’t do any crafting. Then again, @deltasab said they did make them…

It seems to me to be hit or miss whether or not they put them in. I made all the windows before starting a build and none were put in, equally a building was missing some so I made them and the workers carried on with the build…

1 Like

Same happened to me.
When builders finished the wall, started to tear down the scaffolding. They arrived to the place in which th door should be. But there weren’t any doors available. So the build has been stopped.

1 Like

Is there a chance any of you remember how far away your window-frames and door-frames were from the buildings you were constructing? (Conversely, have they ever had difficulty installing windows/doors when the frames were very very close to the buildings?) We have some suspicions about our pathfinder…

1 Like

Not very far at all!

Also no Pathfinder ‘issues’ reported on the performance chart thingy.

At that moment everone looks like they are sleeping, so the pathfinder wouldn’t be working I believe. Was it still the same while they were awake?

1 Like

Just tested if you build a building with no windows/doors they will completely do it with no problems. I then tried to add doors and windows after it and they rebuilt the scaffolding. If you add the door and windows when you first start they 9/10 times dont complete taking down the scaffolding.


excellent observation @hert:+1:

I’m still having the same bug in r118.
The windows will build rarely or not at all. Doors seems to work with no problems though.

I’d say within 20 blocks from the building in question.

1 Like

I’m noticing this in R118. The workers will put the doors in but when it comes to windows they tend to build half a ladder and then down tools even though there are windows available to them.

Had missing windows in serveral games too. Once they would just leave the windows two units above the ground and place the ones I placed higher up on the sides, sometimes they place no windows at all and sometimes everythings just works smoothly (R118).

ok, thanks for the follow-up (and confirmations)… :+1:

Works fine for me!