[Con] Error message when explicitly selecting fallow field in farm


#1

Summary: I meant to try having my farms fallow for a bit at first to see if the soil quality would improve over time (based on what was written in this topic and the description for fallow fields—as a side point, given that soil quality does not seem to improve over time (unless it just takes longer than I had the patience for?), perhaps the description could be such that players don’t suspect that it does? Unless that’s a thing to be added later when farms are worked on more?), so when I first created my farms I explicitly clicked the fallow option, even though it’s already selected by default. This gave me a few error messages each time. Note that I did not get the error messages upon selecting fallow field if I had already selected something else (a crop type) beforehand.

Steps to reproduce:

  1. Create farm;
  2. Select the fallow field option immediately even though it’s already selected.

Attachments:
Error messages at 6:23 and 6:33. No error messages at 18:07.

Versions and mods: No mods, latest release version in Steam at the time of writing, version 0.1.0 (release 122) according to the title screen.

System information:
OS: Windows 8 Pro 64 bits (6.2, build 9200)
Processor: Intel® Core™ i5-3450 CPU @ 3.10GHz (4 CPUs), ~3.5GHz
Memory: 8192MB RAM
DirectX-version: DirectX 11
Graphics card: NVIDIA GeForce GTX 660


Impressions of Alpha 4 Release 122
Farms: fallow fields, crop rotation
#2

Bumping this with a r134 bug along the same lines.

Started a new peaceful game in r134, so far just a stockpile & some harvesting jobs going on - no promotions at all. Set up a few farm zones with each crop, then created one and selected fallow from the list of crops. Result was CTD.

However, picking fallow after first picking a crop, or creating a crop-using field then returning to it to set it to fallow worked without any problems at all.


#3

True, that was the same finding I had/reported, as well. See the video in OP. Thanks for the confirmation.


#4

Ugh. Would you believe this is actually a different bug that just looks the same? Thanks for catching, fixed for next build!


#5

Ah, the old Grasshopper/Cricket bug… I’ll get my coat


#6

if you sayeth, i believeth… i think its the hazel eyes… :eyes:

so, @Teleros’s bug has been fixed, or both? sorry, that sounds awfully nitpicky… :smile:


#7

We do have plans for soil quality, but they are not yet implemented. :slight_smile:


#8

Selecting Fallow in build 134 causes CTD.

Tested on save game and a new game.

  1. Place farm zone,
  2. Drill down to crop placement.
  3. Select ‘Fallow’.

saveFile, Crash dump & log in ZIP