[Con] Crafters refuse to do work

After extended play: Profession like carpenter and weaver refuse to work after a while even when all materials are present. this happens when they start to take couple step and sits down for a split second then repeat. Sometimes they will still respond to gathering request and helps out the villagers.

Addition: the bugged profession will not respond to “call to arms” button (no combat stance like others)

1 Like

hi there @Houten … are there any more specifics you can provide / specifics steps to take to reproduce?

was there something specific you were trying to craft? how long is “extended play”?

about 30min in its when it usually starts, now I’m able to get them to work again by restarting the game. However once they become idle again they will resume the standing and sitting animation.

I have/had a related bug:

  1. Build the workshop but missclicked while placing the stockpile. Went
    back to the crafter list an issued the command to build the workshop/pile
    a 2nd time. Then I got stuck on the info window about the crafter
    stockpile (the one telling you to place it near the workshop, which
    you cannot manually close), the carpenter put one log on the
    workshop and never touched it again. The info window wouldn’t go
    away too, had to restart.

  2. During my 2nd and 3rd run I set up the weaver. During my first try
    he wouldn’t access the stockpile for the plants/fiber, leaving me
    without thread. In all other runs so far the weaver made his first
    threads and cloth but would stop at one point without an obvious
    reason. I think at one point the problem was that I ordered him to
    make cloth but didn’t have enough thread. He then placed the first
    threads on the workstation, realized that he doesn’t have enough and
    left the whole mess.

  3. Closing the station or an empty queue doesn’t help. The leftover
    log/thread just stays on the workstation and the specialist never
    touches it again,

1 Like

thanks for the supplemental details @Accipiter! :+1:

No problem. I was able to reproduce the weaver problem. He gets stuck when you try to craft cloth with only two threads in stock. I also misplaced a way to small stockpile for the weaver (again). Tried the same tricks I used for the carpenter. The first work station (with the faulty/cancelled stockpile) stayed transparent at first. When I placed the new one with the correct stockpile both work stations got build and the weaver stuck between the two when I ordered him to make his first thread. There is currently no way to edit/reset a misplaced specialist stockpile?

The weaver will sometimes not produce anything and just walk around idle. i even have construction going but they do not want to help. In this scenario i have 4 spools of thread in the weaver stockpile and she will not produce any bolts of cloth. also she/other workers have left almost all of the silkweed fibers in the field where they were found (naturally not farmed). i have tried reinstalling the beta which let me make the 4 spools of thread as before i could not create any.

Oh, thanks for reminding me! Yes, I noticed something similar, except for farmers. I believe the farmer was one of the classes meant to help out with regular work if they’re otherwise not doing anything, just like the weaver, which is why I agree it’s probably a bug.

I have had the same problem. I have all the fibers I need to make thread but my weaver doesn’t make any thread at all. And yes, I have tried to close and open the workstation.

And It happened again. Same as before, made some thread and then asked for cloth, instead of making it the weaver just stands there. Not doing anything.

Try saving and reloading, i had the same issue with the weaver and carpenter and sometimes it fixed the issue.

This is in Alpha 4.
After I set up the building: floor, wall, roof, and doors/windows, the workers will begin building the structure but after awhile they just stop and leave the build unfinished. Even when there are no other tasks they just idle as if the building was finished. Is there a solution to this?

two or three reports merged into one… a confluence of confirmations!


A solution to this is to go into build mode and re-select the building and click remove, then start building and yes.

Same here! I have a few workers who remain idle even if they’re hungry and the building is incomplete. Even if I reselect the building, they still won’t get to working.

I am currently in Alpha 6 and still having this problem, it normally happens after i build a house where the carpenter and weaver just wont work, that do everything but make what i have put in their workshop? can i ask if you are close to fixing this? as this problem is holding me back from progression in the game. normally happens in about 20 minuets as well.