[Con] [A9 r256] Game hitching every few seconds

Title:
Bug: Game Hitching Every Few Seconds

Summary:
In game, every few seconds it will freeze. Immediately after it unfreezes, lua will take up over 80% of it before immediately falling down again. This repeats every few seconds. This occurs even if there is nothing going on (over 80% idle). This has happened to me in two towns. One town had about 20 villagers when it started happening, the other had 14. According to sakinoko, he had similar problems at around the 14 villager mark. Only villagers, animals, and light animations freeze. I am still able to move the camera and interact with menus during the freezes.

Steps to reproduce:
As soon as the 14 villager came to my town it started hitching.

Expected Results:
Expected it to happen at around the 20 villager mark like my first town.

Actual Results:
Happened at 14 instead.

Versions and Mods:
Release 256 (x64), vanilla

System Information:
Windows 7 64bit
i5-4670k @3.40GHz
8GB of ram
EVGA GTX 760 2GB video card

(Edited 4/1/2015 5:50pm EST to fit bug report format)

1 Like

Welcome to the forum, @SenEvason! :smile:

Could you post your system specs, please?
And which version are you playing? (I assume Alpha 9 r256)

In game it reads “release 256 (x64)”

My specs are:
Windows 7 64bit
i5-4670k @3.40GHz
8GB of ram
EVGA GTX 760 2GB video card

Also, hitching occurs no matter what the game speed is (except for paused for obvious reasons), and while it’s hitching, I can still move around, select objects, and mess with the menus. It may also be independent to that particular town. I started a new town and it seems to be problem free so far. I’ll try to get it to the same level as the other one and see what happens. Would attaching a copy of that particular town help?

1 Like

SenEvason, I am also experiencing this issue and have similar PC specs (albeit older gpu gtx 670). It started for my current town around the 14 villager mark.

I started my town with two max size (20x20) farms and they have been fully operational for the entire game. I really noticed the hitching when I was getting deep into mining and revealing a larger portion of the map. I had every profession (aside from herder) working in several areas and have no buildings yet (just a row of beds). Once, I hit the 20 villager mark I’ve noticed the bar on the bottom right shows mostly blue for periods when the 1 second freeze happens (everyone stops acting, but camera and menu controls are unaffected). When my first goblin camp arrived, until now, the AI freezes have been 1 second every 5 seconds.

If you guys (Radiant Team) need any more information please let me know. This bug really kills the game after reaching an established point since everything gets extended by 12 seconds every minute.

Sitting at 22 villagers, may have started at around 20, I don’t remember exactly. I had a goblin camp for a long while before the freezes started. Very little mining or exploration done, a lot of buildings, some farms but not much. With your experiences as well, sakinoko, it may be villager related.

Also, it’s not just villagers that freeze, but the animations for lighting as well.

Also having this bug, every few seconds the entire game stops, but I can still move the camera, and when it unfreezes lue spikes to over 80%.
My specs are similar to @SenEvason

God i am happy i am not alone who is getting these lags. It is really annoying and i posted it too

We need to solve this :frowning:

http://youtu.be/Q5yi2nfTXxg - video of my hearthlings

1 Like

Thats my problem :frowning: I tried restart, unistall, graphic low/high and nothing happends. Still getting lags and is unplayable.

64 bit and 32 both lagging.

Dell VOSTRO
i7-3770
3.40GHz
16GB RAM
64-bit OS
AMD Radeon HD 7700

1 Like

So while I’m playing errors keep popping up saying "attempt to index local ‘entity’ (a nil value), here is a screenie:
http://postimg.org/image/y2ittp9eb/
Is there a way to disable the error console? I don’t really see any effects of this error in the game, and it just pops up every few seconds.

One more thing, the UI and the hearthlings freeze every few seconds but I can still scroll and move the camera around, and I noticed that every time it freezes the “lua” thing in the left bottom corner spikes to more than 80%.
Anyone else having these?

Welcome aboard, @AppEx213 :smile: !

If you are getting an error every few seconds it means an infinite loop and that’s bad.
And the freezing is worse.
Could you post your system specs in the meanwhile we get some confirmation from any other player that has the same issue?

Having the same issue.
Operating System: Windows 8.1 64-bit (6.3, Build 9600) (9600.winblue_r8.150127-1500)
Language: English (Regional Setting: English)
System Manufacturer: MSI
System Model: MS-7640
BIOS: Default System BIOS
Processor: AMD Phenom™ II X4 965 Processor (4 CPUs), ~3.4GHz
Memory: 8192MB RAM
Available OS Memory: 8192MB RAM
Page File: 4648MB used, 11735MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.03.9600.17415 64bit Unicode

1 Like

Here are my specs:
Intel® Core™ i5-3470 CPU @ 3.20GHz
NVIDIA GeForce GTX 670
8.1 GB RAM
Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 64-bit

1 Like

I’ve found a similar thread: [Con] [A9 r256] Game hitching every few seconds

1 Like

Do any of you guys have your villagers mining? I suspended mining and it cleared up for the most part(down from 99% Lua to 70-80%)

i’m on hearthling 22 now

Mining didn’t have any noticeable effect for me. One town I did almost no mining in, and my second town I did a lot. Both still lag at 80+% Lua.

this game need too expensive computer. my game freeze every 3-5sec. freeze is about 1-2sec long. i have low settings. still. and so much lag. :confused: my computer cost now about 700€ so. and this game eat so much memory. i have 8gb memory. i cant play anymore at all. i have 16-19 guy in my town. waiting new patch :confused:

Could you post your system specs, please?
It’s helpful for the developers to know the range of systems that the users have.

Bear in mind that most players don’t recommend to play with more than 12-13 hearthlings in the town. The game still has performance issues.

You don’t get 8.1gb of ram :] you mean 8gb, right?

will this be fixed on next update?

Hello, again,

I have around 21 Hearthlings in my villiage, and about every 15 seconds, the entire game itself (Not UI freezes), such as fire braziers, animals and everything else in game. After about 10 seconds, they all unfreeze, and then freeze, and then unfreeze etc.