Carpenter stops working


#1

My carpenter stopped working recently, all he does is build and haul but doesn’t complete tasks for the workbench. I can’t progress in the game because I need to make more bows as Northern Alliance to get to township level 2 and get my hearth. This started happening after I killed the first big orc camp and clicked the dirt pile to reshape the land. I’ve tried saving and reloading the game, demoting and re-promoting him to carpenter and nothing is fixing it.


#2

I dont know why but my weaver dosent work with his items either.


#3

Can they reach the ingredients for the current recipe?
Can they reach their workbenches? There was once an issue with someone that put all the workbenches nest to each other inside a small cave, and the hearthling needed to stand on the side of the spinning wheel, but couldn’t because it was blocked between the wall and another workbench, which led to him not crafting.

If you upload the savefile we can investigate.


#4

I have the same error myself. He have a carpenter house (Crafted from template) which have been used for a long time and works perfectly, so he can most definitely reach the workbench. The weird thing is: He crafts some things like large crate, but a leather bound chest dosen’t work. It have worked earlier, but now it seems to have randomely stopped working. Have tried to save/reload and it dosen’t work.

Help? How do I upload the save file?


#5

Have you tried removing the existing orders and making new ones?


#6

@kimvalde, are you sure that the carpenter can reach all the required ingredients?

If you want to upload the savefile, here are some instructions:

  1. Find the save folder for the saves you wish to upload. By default, they are located in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install).
  2. Zip the folder.
    1. Right click the folder (should be a long set of numbers).
    2. Left click on Send to in the menu that appears.
    3. Left click on `Compressed (Zipped) folder).
    4. (Optional) Rename the folder to something different than the default set of numbers.
  3. Upload the save.
    1. If the zip is less than 10 MB, you can upload it directly. Either use the upload button or drag and drop it into the compose window,
    2. If larger than 10 MB, upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.

#7

Yes I’ve tried several times. He can make basically everything I want him to, except the leather bound chest, although I have all the needed ingredients. He just glitches betweens getting ingredients and resting by fire over and over, and never actually starts to craft the chest :confused:

I’m very new to this game, started a few days ago, but why isn’t my Black forest inn and Tavern finishing?

Sharling link since 10.7 MB --> MEGA


#8

@kimvalde, effectively your carpenter can’t reach the bolts of leather needed to craft the chest. They’re above your weaver’s house, not sure how so many items ended up there. Place a ladder so that hearthlings can reach them.

One of your houses finished building right after load, and the other one needs a rug that’s also on top of the weaver’s house roof.

Remember not to mess with the ghost items of buildings in progress, nor modify the items in them until the building is finished, it’s not supported and can cause issues. After the building is finished you can move/remove/place new items in it through the placement menu.


#9

Ahh thank you so much!! Have no idea how these items ended up there myself, I only built the weaver’s house from the template :confused: And yes both buildings finished now, so no problems anymore!

Thank you for your quick and great assistance and for an awesome game! :smiley: