Can't save after a certain time (out of memory in 32-bit)

Hi everyone, I play on alpha 9, when i begun my first game everything worked well, i could save whenever i want.

But suddenly, after 2-3 hours, the saving didn’t want to work anymore. Trying to overwrite or create a new save just show the “Saving” on the screen for one second, and disappears, the actual save didn’t change. Activating auto-save has the same result, after 5 minutes nothing, the game just don’t wanna save any more.

Reset the game is my only option, but it really bothers me because nothing can show you that the saving stop working ingame, and the spacing between bugs is reduced to as my game advances, which makes it quickly unplayable.

If someone already encounter this problem, or have a solution, and sorry for my bad english.

hey there @CaptainVodka … welcome aboard! :smile:

is your situation similar to this report?

thanks :kissing_smiling_eyes:
no, when the bug happens both can’t work, tried to enable/disable auto-save and manually save but nothing works

do you have any saves still in the “save menu”? specifically auto saves.

I only have 2 save showed in the save menu

ok so its not a case of the auto-save priority then, hmmm… and your sure its not like the one that @SteveAdamo mentioned?

(Release 453 x32 build)
I am currently unable to save my game… more than once?.. This bug is really confusing as it only allows me to save my game one time. When I try to create a new save or override my current one, it just shows the “Saving…” message for about .5 of a second and then it disappears and doesn’t save. Combine this with occasional crashes and you can bet I’m in for a frustrating experience…

Please help? q.q

I have exactly the same problem you are, with like… everything exactly the same. I’m sorry I can’t provide any help but I know what you’re dealing with.

Just save very often, as the bug seems to be random. Try not to use the console or overload the AI with too many jobs/buildings… other than that I don’t know. If it happens at the very start of a game, save every minute or so. If that’s not enough, save twice in a row and reload the most current. This bug also seems to remove auto-save games and cause the game not to auto-save.

That’s not my problem at all… I said that it only let’s me save once in a row, I can’t reload the game, I have to literally close the game and re-open it before it lets me save again.

I save > time passes > I try to save again > It doesn’t work.

It only lets me save ONCE…

Have you tried saving twice in a row, without overwriting?

I can save about 4 times by creating a new save, but then it does the same thing.

So you can save the file, but you can’t overwrite it, is that what you’re saying?

Have you tried disabling shadows?

Weird thing to try, I know, but just in case :confused: (it was an old workaround for problems when saving).

Other than that, this bug looks pretty bad. Could you upload you stonehearth.log after a failed attempt of saving (when it doesn’t save)?
I’m not sure what can be affecting here…

@Relyss I’ve been having the same issue. Though I’ve also been running Stonehearth on OSX using Wine (It actually works with better performance than I get on Windows :stuck_out_tongue: ) so I simply decided not to complain. However as the issue was evident with someone else I decided to install a copy of Windows and test. So after a little digging these are my results so far.

When trying to create a new save the “Saving…” text flashes and Stonehearth creates a save folder, but it leaves it empty :frowning:. Nuking all directories didn’t change anything. Bug seems to happen somewhere after the beginning of the game. It seems to happen as a result of certain actions, so far I’ve found it while mining, removing berry bushes, looting and building. However deleting all broken save folder and then continuing from the latest working one seems to work.

Here’s my log Dropbox - SHSaveBugLog.rtf
StoneHearth 0.12.0 (Release 465) x32
Shadows is disabled.

Sadly this bug is kinda game-breaking as I have to restart from an earlier point of time regularly. (Still won’t stop me from playing.)

Hello @victorzimmer. Have you tried Alpha 13 and see if the bug persists?

Do you have any mods installed?

There is an Alpha 13? :smiley:

I haven’t got to trying any modding yet.

Yup :smile:

Well all my saves are now missing :open_mouth: (Might be StoneHearth, might be Wine) anyways, give me a few minutes to get somewhere in a new game :smiley:

Also I must say there is a certain beauty with StoneHearth running on OS X Dropbox - Screenshot 2015-11-28 21.35.46.png

Yup, got the same bug in A13 :frowning: