Can't Build Houses


#1

Title: Unable to build simple rooms. After placing a blueprint down, game freezes then crashes to desktop with no error.

Summary: I cannot get my workers to build a simple room. I can place it at the beginning of settlement, but if I have some workers performing a task (ex. cutting a tree) but if I have a worker cutting a tree, it will crash to desktop with no error.

Steps to reproduce:
1)Settle a city
2)Have workers cutting a tree
3)Try to build a simple room

Expected Results: For the blueprint to place properly and be built.

Actual Results: Results in a CTD with no error.

Notes: If workers are picking berries, it will not crash. However, if any workers are cutting a tree the game will crash. I figure this is related to the pathfinding bug mentioned in the people standing around with logs bug thread.

Attachments: None

Versions and Mods: Alpha 1, no mods

System Information:
CPU: i5-3570k 3.40 ghz
Ram: 16 gigs
GPU: Nvidia 670 gtx
Windows 7 Home premium 64-bit


#2

The game has issues with placing houses over multiple terrain blocks. If you press F1, the blue rectangle indicates where a terrain block is, and for now just build your buildings inside just that.

The Team are working to iron this out though! This is just a workaround :slight_smile:


#3

Thanks for the work around!


#4

But roofs aren’t build even with this workaround, are they?


#5

That is true. There is a bug currently where roofs will not be built.


#6

i just saw this on Curse… might be of interest to @sdee and co.

it seems that promoting all units (but one) to carpenter, leaving only one unit to build walls/houses, makes the process more likely to succeed…

http://www.stonehearthguru.com/forums/alpha-beta-testing-nexus/helpful-resources/49475-current-workarounds-try-these-if-youre-stuck#c15


#7

Yes! Good to know. Thanks!

Lord Rahl! We are honored that between your many adventures and administrative duties you have found a few moments to build a structure in our humble village. P.S. Say hi to Lady Kahlan for us.


#8

could your nerdiness be any more lovable? :smile:

p.s. Cara sends her best, and asked if you might be interested in joining the “sisterhood”…


#9

That post is wonderful I… good choice of reading material. Can I like it multiple times? Guess not.

Oops time for devotions.


#10

I love playing Diablo with my dad too much, thanks. :wink: But thanks for the offer! Honored, so honored. ::runs::


#11

Sure, you get an offer to join, what do I get?

Nothing. Not even a complimentary place mat.

Absolute disgrace.

I should probably write something to keep this on topic but.


#12

you didn’t met certain, ah… prerequisites

as for an OT comment, perhaps someone can test the single worker/improved efficiency theory? :smiley:


#13

This is completely anecdotal … but I imagine only having one settler building stuff would prevent a lot of the pathfinding errors?


#14

absolutely! but still worth “proving”, for those with slight to moderate OCD…


#16

So, since I’ve gotten home, I’ve been building houses. Whole houses (minus the roof of course).

I’ve set 5 of the 6 villages to be carpenters. Leaving one lonely worker to build houses, pick berries, gather lumber, and light the fire for the rest of them.

I’m at 3 (and counting) houses that have been completed by this method.


Of course, as soon as I open my mouth, it breaks. But not because the one worker forgot what he’s doing. He got stuck inside the house. The scaffolding is blocking the doorway.


#17

excellent! i’d say thats a worthwhile data point… :smile:

and yes, this is another known/logged bug report… thanks for the detective work! :+1:


#18

My problem is during the building of the house the ai’s suddenly will stop, and go to the stockpile to grab wood. While standing there they will either stand their with wood or continue to pick up different pieces. I tried to reset the ai but they don’t respond, also I assigned them different tasks to try to pull them away from the stockpile, but they just go back to standing at the stockpile after doing the task. They still get tired and lie down but then they go back again to the stockpile.


#19

Have you tried creating another stockpile? Or deleting that stockpile?


#20

Ah, great idea!
I will give that a go.


#21

I used the idea to delete fields that the AI were loitering at; however, when I created an new stockpile they brought the lumber there and began the pick up/put down bug.

I went ahead and tried other things as well; assigning multiple building jobs and creating multiple stockpiles for resources near each project.

In all I created 4 small houses with 4 resource fields right next to them. From a fresh load the projects began working fine, most of the structures completed over 25% of the walls, yet as each project furthered their work the pathfinding resource monitor began to creep towards 99%. When the full resource group was fully yellow (pathfinding) the AI stopped all building activities and stood around until the needs AI took over the behavior.

There is no method I know of to reset the resources, and the debugging reset AI control does not appear to free up the current pathfinding issues. Once the resource bar is at or over 90% the only option is to restart the game.