Building Separate Rooms Gives Error

So I was trying to make rooms that were completely separated with a wall. The idea would be that the only way to get between the rooms would be with a door. I tried drawing it with the wall segment tool and then adding a door, but it was tedious and the door is one voxel deep into the floor.

The next thing I tried gave me an error:

Steps to reproduce:

  1. I built the floor of one room.
  2. I used the tool that raised walls around the entire perimeter of the floor.
  3. Then I tried placing the floor of the second room up against the walls and got this error:

Is this something that will be easier to do in later versions? I hope so; I can’t imagine that it wouldn’t be.

1 Like

I don’t think the game supports annexes to buildings in the building tool. I think the error you are getting is because the builder is trying to place a wall around all four sides of the floor but it cant.

You should always have a minimum of 3 tiles gap between the buildings to avoid problems. Including the walls, this means you need a gap of 5 between the floors.

If you want to build an L shaped building like this, draw the floor in the shape that you want the final building to be, and then place the walls. Interior walls are not supported at this time either.

1 Like

Gotcha. Do you think they will be in the future?

I certainly hope so.

@Ponder would know for sure, but I should imagine this would be possible

Great. Thank you for your input :smiley:

1 Like

I know this is an old topic but I don’t want to start a whole fresh topic for the same/similar issue

Using A9 r256

If you follow the second set of steps listed above and get the error and then try to use the remove tool to remove the building you’ll get a bunch of extra errors and the building wont remove (saving then loading allows for removal)

Suspect this is just standard SH error handling process, which I must say is pretty impressive most games/applications would just crash.