Building problem due to scaffolding

My test today was to see if the hearthlings could dig/rebuild a troglodyte house. The goal was to get a green roof where one could farm his carrots in peace.
Well, it’s doable… almost… :unamused:

Let’s see what happens.

The first step was to plan an dig all the necessary. Of course, because this was a test only, the instant mining was more than welcome. Once done, the first step of the building could begin:

Then, the work stopped for some weird reason: apparently the hearthling couldn’t access this zone (red arrows):

The only actual solution to help them out was to build a few ladders in place of missing scaffoldings:


After a few minutes, the first step was completed.

The second step was building the upper part of the walls so I made my blue print and fatality, no one react at the build order. Here is the plan and probably why the hearthlings could not begin, some blocks were possibly unreachable at this state of their AI (blocks under the red arrows):

So cancelation and creation of a new blue print but this time, the upper part had to be divided in two phases. First I left the access to the suspicions blocks like this:

Then finally the second phase could end the building without more problems ending by the same the initial two steps construction.

SO definitively, the construction AI can receive much more love because scaffoldings are great but many times they are useless (a scaffolding to build 1 block on the ground? Come on! :stuck_out_tongue_closed_eyes:) or misplaced (sometime one need to add a ladder to fix a situation) or missing (like today case in the inside of the house).

A little search on the board shows me the problem isn’t new at all! In my humble opinion, next to a better pathfinding, we do urgently need a stronger construction AI!

@sdee , I hope this illustrated feedback will help for further intern serious testing.

Btw, after all these efforts, the hearthlings were in need of cold beverage and tasty food, so quickly I end up the scenery like a typique french square with tables and seats in the shade of an ancient oak tree:



thanks for the report, the amount of depth you put in it should help TR find/fix this bug.

P.S. that town is amazing!


How did you add water?

Absolutely love the town! :smiley:

1 Like

Woah! That looks absolutely amazing! How long did it take to finish this town?

1 Like

That’s so neat! Beautiful layout.

Woah! That is cool! How’d you get the giant tree in the middle of the dug-out area?

Also, relating to scaffolding problems, when I build a two-story house with a one-story ‘front’ (i.e. where you see the doors placed in the building templates for the Radiant dining hall and shared sleeping quarters), after the Hearthlings finish with the first story, including the one-story roof, they start on the second floor and end up building scaffolding through the roof from the ground inside of the building to finish the second story. Now, this wouldn’t be a big problem except -

  1. They rarely ever tear the scaffolding from the front of the building all the way down when they finish. So they leave a scaffolding up inside the building as well as sticking out the top of the first floor. Sometimes if I build ladders up ontop the roof, they will take down some of the scaffolding for the second floor but not inside the building.

  2. This happens on both Alpha 10 and 11, and one of the times on Alpha 11 they instead built the scaffolding ontop the roof for the second story, instead of building it up through first floor. I presume that would be the desired behavior?

I know I could completely bypass the whole problem by using the instant build command or deleting the scaffolding, but I’ve found that using the console seems to produce game-breaking bugs and errors for me. Any additional info I’d need to provide, I could! (Don’t ask for any of my payment info! Off-limits, even for Stonehearth!)

1 Like

Tx for the comments guys but this is definitively not a town, at best a draft no more!

So @IvorySteam, to finish the scene it took ~3 hours. Don’t forget this wasn’t a classic game, just a test so I took some liberties with instant mining and the drop tool from the dev kit. So no great challenge here!

@kekikcilerakin, the water comes from a lake on top of the nearby mountain. You need first to carve all the needed canals then once all is ok, you open briefly the flow and that’s it.

@MyCoal417, the oak was placed with the drop tool. Concerning the issues with building, actually the best is to work step by step. If you want a complex design, the best is saving between each steps. If the next don’t work as expected, reload and try something else. Of course it’s a pain but don’t forget we are in Alpha. The dev’s will soon or later fix the issues we met now (there isn’t many choices anyway for a building game!) so patience is the key.
Instant build is a solution if you want cool stuff quickly but if you want to deal with the challenge offered by this early stage, then you have to find a way to bypass the bugs.


@Beatrice, thank you so much for the inventive design (for sure we’ve never tried to test something like this) and for the step-by-step creation diagrams. We really appreciate it. Also, your build is lovely!


Today I’ve been in more troglodyte type test building but this time much simple because in mountains so no green roof to deal with.

All went pretty smooth because still no complex houses but looking at the hearthlings at work, I saw a few things I want to share with you and the dev’s of course (-> @sdee) .

So a few more picts, it’s easier to understand.

First, again a 2 steps building, basement + wall + door and same problem as seen above, needed a few ladders in place of inside scaffoldings:

Here is the blue print for the second step, very simple:

And now the funny part concerning the scaffoldings; see the guy with red arrow?

He is building a scaffolding while the others are already on the roof ending the job!

So in this test, in many cases, scaffoldings where useless because there were some paths to reach the job due to the rocks all around. Too bad the poor guys had double job while the others were resting! :stuck_out_tongue_closed_eyes:

Another point, this time of importance, look at this picture:

One problem are the pillars. They block the path on the top of the walls. I understand well the idea, first the structure, then the walls (like in real world) but I’m pretty sure it would be much efficient if the pillars were build at the same rhythm than the walls, one level after the other.

Another pict to show something interesting for the one in charge of the construction AI:

The hearthlings could use the red path without problem, right? But no way because they were expecting an external scaffolding so the work stopped. Too bad!

So looking closely to these cuties in action make me say the 2 actual major problems with the construction AI are the scaffolding management and the pillars AND my guess is the pillars problem is responsible for many many building failure.

Hope that will help!

PS, for the curious, here is the scenery by day and by night (love the last one! :blush:):


thanks again, for compiling these step by step instructions/bug reports, it really does help TR

you are an amazing builder, you should share more of your towns on the discourse!


I have to say I’m not sure what you’re talking about. :confused:

And on my most recent save, building a ladder up to the first story roof somehow got the Hearthlings to demolish the front scaffolding from the ground floor. If I recall, in the save before that, it didn’t work. Huh.

But buildings like yours is why Stonehearth is definitely worth the $25. All the potential, all the coolness. Now if only I could get my friend to actually buy it, the pirate :angry:

1 Like

@Beatrice, thank you so much for the bugs and the build! We are inspired. :slight_smile: @not_owen_wilson hopes that the new pathfinder will eat some of these problems for breakfast–so stay tuned!


Do a search on the board about the “DebugTools”.

When a new build pops I’ll reroll a few similar tests to see if things are better so more feedback to come on this topic.


[quote=“Beatrice, post:14, topic:14842”]
Do a search on the board about the “DebugTools”.
[/quote]or go to the download page, GitHub - stonehearth/debugtools: Stonehearth Debug Tools Mod

1 Like

Ok, I’ll check it out

1 Like

Hi. Thanks for the super detailed report! I love your designs, btw. Chris just checked in some fixes to the way we decide what side of the wall to build scaffolding on which may correct the errors your seeing. We’ll push those out in the next Alpha build. Let me know how it goes for you!


@Ponder, no problemo but my guess is this + the new pathfinder = all good! And if things are as expected there will be no need to touch the pillars vs walls code…
So more feedback on the next build. And Tx for the kind words! :blush:

1 Like

So here the new test with the scaffoldings version 2521.

There is some good points but we now stumble upon another already reported “feature”: hearthlings need to build the scaffolding to the top raw of the construction to achieve it. And in the present case, they cannot because they need 3 blocks high of freedom. The result is they cannot build the last 2 raws.

This is not new, the same occur in a cave for example.

Here a screen to illustrate:

I had to mine the red zoned blocks to let them build the green zoned ones. Now there is something odd. Why the hell couldn’t they build the green zone when they have already build the blue zones? Well I think the blocks in the blue zones where done before the scaffolding was raised.
So the point is perhaps this one:
When a raw is completed, the scaffolding is raised by one. BUT actually perhaps the hearthlings can build at +2 and even perhaps +3 block above the scaffolding level. The problem is they don’t have the time to do so because others hearthlings will raise the scaffolding without waiting.
As a reminder, look again at picture 3 of this thread, the ladders were 3 blocks high and the hearthling could build the 3 missing top raws.
So here the solution would be to let the hearthlings build as much as they can before the scaffolding is raised.

Another oddity:
In this troglodyte test, all the scaffolding where placed in the inside. Actually I found it strange because the front face of the construction is totally free and could be build from the outside.
So I’ve done a little test on a side, a simple building touching the cliff:

As expected, 3 scaffoldings are outside and one is inside. So all blue arrows are correct while you can see in red the misplaced scaffolding on the troglodyte construction. No idea why…

So @Ponder, @not_owen_wilson, you aren’t far guys, courage! :sweat_smile:


My suggest is that you guys could set height up to 4 as don’t need scaffolding :smiley:
However, I tried to create an “in-cave” cantine, but both standard wall and single-block wall need to be built from outside the room (or from inside the cave wall if you prefer). I had to dig all around the building I want to build.
Then, there is an error that happened when placing an interior wall (screenshots in some time).