[BUG] Won't build with clay bricks

My citizens refuse to build with clay bricks and they aren’t showing up in inventory. This makes it impossible ot play as the “Rayya’s Children” race.

Steps to reproduce:

  1. Make Clay bricks
  2. Build house that requires clay bricks

Expected Results:
They build the house

Actual Results:
The clay bricks don’t show up as an available item in the required items for build

I have tried to create stockpiles with no filters, they collect the bricks but they don’t register in the inventory and thus don’'t build with them.

Version Number and Mods in use:
0.17.0 (release 593) [No Mods Installed]

Am i the only one having this issue? I have already reinstalled the game, verified files (through steam) and googled this issue but no-one seems to be having it but me :confused:

Are you sure it is clay bricks and not normal clay? You need to fire it in the oven to make the bricks used later in building.

haha yes i am sure. I’ve been playing the game for some time now and have never been able to build with clay bricks. Thought it might fix itself over time with updates and whatnot but now i’m not so sure…

upload your save file so the devs can take a look

I have found the location for the save files but i am not sure which file to upload.
There are 3 files (+Screenshot for save):

Or should i upload all 3?

here is a quote from our senior support crab:

1 Like

Sorry, i edited my reply just before you posted that :slight_smile: I knew where the saves were, just wasn’t sure how to upload, but i found that too and now not sure which ones to upload.

zip all 3 files and upload the .zip file

client_state.zip (6.6 MB)

Save file zipped. Fingers crossed this issue gets fixed, i would love to play as this race, not being able to basically makes half the game unplayable :frowning:

Thanks for your help jjjshab

Hmm, I’m getting this error upon loading your save:

release-593 (x64)[M]…components/resource_node/resource_node_component.lua:9: attempt to index local ‘json’ (a nil value)stack traceback:
[C]: ?
…components/resource_node/resource_node_component.lua:9: in function <…components/resource_node/resource_node_component.lua:5>

I then noticed that the uppermost item in the potter cue seems to be broken as it’s missing an icon. Deleted it and manually added some clay bricks into the cue. The potter then started producing clay bricks and shortly afterward the workers did in fact start to build the house. Dunno what might me the reason on your end.

Have you tried verifying files (right click on Stonehearth in the Steam library > Properties > Tab: Local Files > Verify Integrity of Game Cache)?

Out of curiosity: I’ve overwritten you game save. Does it fix your problems when you load it? 1470316583780.zip (6.2 MB)

Yeah i have that issue as well. There’s a few items that don’t have images or the hover text (eg fur beds, decorative statues) they don’t show up in my inventory or are gathered in stockpiles (so i can’t even just sell themto traders), but the clay bricks is more of an issue for me atm. I will try your new save and see how it goes. I have verified the files a bunch of times but it doesn’t fix the issue :frowning:

So i loaded your updated save and they are continuing to build the house but unfortunately i am having the same issue when i try to make more. It registers the 32 bricks you already had in the inventory but when i get the potter to make more they are not showing up in the inventory again :frowning: I have no idea why this is occurring, especially as you seem to have gotten it working fine for yourself. Maybe the game just hates me? lol

Strange indeed. Have you tried deinstalling Stonehearth completely manually, not just through Steam, before reinstalling?

I have uninstalled through steam, windows and even deleted the entire folder and reinstalled…

The game doesn’t have fur beds and statues, so you are modded, and will need to check which one is interfering with it.

1 Like

Hmmm, that’s strange as I have never installed a mod. Might have to talk to my housemate. I’ll check for mods and delete in the morning. I’ll let you guys know how it goes, thanks for picking up on that too, fingers crossed this fixes it. I’m excited!

Try removing one, testing, repeat, until it solves. This way you will know which mod was causing the problem (that is, if it is caused by a mod).
stonehearth.smod, radiant.smod and both rayya.smod should not be removed as they are the main game, everything else are external mods.

Thanks for the help, i do have a mod installed called settlement decor (i forgoti installed this when the game was in early release) I will try removing and then test play. But i have another on there called rayyas_children_ui.smod Is this a part of the base game? I don’t remember ever adding this one and not sure what it is.

It is, this mod is what changes the ui when you play with Rayya, so the interface is different from the one when playing with Ascendancy. It is part of the game.