Bug: Floor material cannot be altered in existing buildings templates

So there I was, making changes to the new templates that the developers provided as defaults for beginners. the columns, walls and roofs materials can be altered during planning but the floor plan designs cannot be changed. it just give me a window reporting an error. I tried to change the floor plan manually but it is not saved in my template and the building refuses to get finished with the missing floor. I hope this report will be answered with a fix for the bug.

I tried to upload the screenshot of the error but your forum won’t let me due to me being a new user so I typed it down down instead.

Message: Uncaught ReferenceError: toolID is not defined
line number: 204
char offset

hope this can help.

1 Like

Can confirm! See my attached video for R210.

At 3:28, you can see I select the template “tomo lili pi kasi kiwen”. This should be a little wooden house (language: Toki Pona) which was edited from an earlier-created template “tomo lili kiwen”, a little stone house. tomo lili kiwen used stone floors and walls; I changed both these material types to wood when creating the new template. However, the buildings I placed from this template still used a stone floor (see 4:38 in the video). I then check the template, and indeed it suggests rock materials are needed, but in the template itself it says a wooden floor plan is selected, as intended.