Exploding Template

a19r687
building

#1

I have an interesting bug that has I have come across after spending several hours building a template for a castle. After saving the template and trying to place it in another game, the levels of the castle go flying all over the map. see picture below, attached is the template object.

https://drive.google.com/open?id=0B9bUZaOwhIGGaW13cFZ6bFhpdzA


Broken Templates
Blueprint exploding when placed
Error on placing building
Engine error while placing templates in r767
Building template bug
Cannot complete building
Missing Buildings From Templates
Custom Buildings Not Loading
#2

Hey there @brendan_ms, can you check the sharing permissions on that link? I get a “You need permission” screen when attempting to open it :frowning:.


#3

@jomaxro

https://drive.google.com/file/d/0B9bUZaOwhIGGaW13cFZ6bFhpdzA/view?usp=sharing

sorry dont use google drive much i think this link should work.


#4

No Problem!

Yep, and it fixed the original link as well.


#5

As a side note to this, I did have a copy of this castle that is just the foundation of the castle. I am able to place that and start building it, but the construction of this part makes the game shudder while they are placing the stones. It makes the lua portion of the chart go to 99%

I can share this part when i get back home, but the build request requires 2900 stones, and 9 wood. So it just may be the massive amount of work required to build it.


#6

Paging @albert, have you been able to look at this build?


#7

Unfortunately not. We haven’t had much bandwidth to look at building design bugs recently.


#8

I’m new and this probably have already been brought up but it’s bugging me hehe Anyway whenever I go to place a custom building template the thing just explodes and goes everywhere and an error box pops up. Anyway to fix this or is this just a known bug? I also notice it places just fine unless I rotate it any way.


#9

Welcome to the forum, @RoamingHobo :slight_smile:

Which Stonehearth version are you playing, and which version is the template from?


#10

Both are from the newest version Alpha 19.


#11

This is the Blueprint prior to placing it.
http://images.akamai.steamusercontent.com/ugc/433823760626906876/0B3A134F761C246220304E8CC42355188EF25EC7/

This is what happens when I place it.
http://images.akamai.steamusercontent.com/ugc/433823760626907744/5546051DCD9A055CC8DFA1E363FD66FF25886458/

Yes, it is within walls at the moment, but I did try a new place, and placed it just in an open field and it also exploded.

It is made of 3 walls, with a free tool created roof.


#12

There are a lot of bugs and problems with using the slab tool to create advanced or complex structures. Things like arches are sometimes impossible but have been known to be built. For now, the Hearthlings just can’t comprehend stuff like that. :frowning:

Your best bet, though, is to try and get rid of the blueprint and try to build it again. Perhaps open up a new town and see if they have any problems?


#13

Yeah, I’d tried a new town without anything on it and as soon as I placed the blueprint it exploded. There was also a treehouse (On the top of a tree) that I built that also had the roof section not sit correctly on the base.


#14

For reasons I don’t understand, all of my custom templates are suddenly broken. I was just playing a save like normal, I removed a building, and after I noticed none of my templates worked anymore. I went back to a save before removing the building and the templates were still broken. Closing and restarting the game doesn’t fix it either. This is the error message I get when I try placing a template.

release-687 (x64)
No matching overload found, candidates: luabind::object load_json(lua_State*,std::string const&,bool)
stack traceback: [C]: ? [C]: in function ‘load_json’ radiant/modules/resources.lua:33: in function ‘load_json’ …/fixture_fabricator/fixture_fabricator_component.lua:361: in function ‘_get_rotation_tweak_xz’ …/fixture_fabricator/fixture_fabricator_component.lua:436: in function ‘rotate_structure’ stonehearth/lib/build_util.lua:562: in function ‘rotate_entity’ stonehearth/lib/build_util.lua:566: in function ‘fn’ stonehearth/lib/build_util.lua:172: in function ‘for_each_child’ stonehearth/lib/build_util.lua:565: in function ‘rotate_entity’ stonehearth/lib/build_util.lua:566: in function ‘fn’ stonehearth/lib/build_util.lua:172: in function ‘for_each_child’ stonehearth/lib/build_util.lua:565: in function ‘rotate_entity’ stonehearth/lib/build_util.lua:580: in function ‘restore_template’ stonehearth/services/server/build/build_service.lua:1616: in function ‘build_template’ stonehearth/services/server/build/build_service.lua:1607: in function ‘cb’ stonehearth/services/server/build/build_service.lua:1582: in function ‘do_command’ stonehearth/services/server/build/build_service.lua:1606: in function <stonehearth/services/server/build/build_service.lua:1604>


#15

That’s weird, I have no problem with templates. How old are your custom templates?
Could you upload one of them?


#16

I can try. some of them aren’t that old. I’ll upload the first one to give me trouble. I’ve had it since alpha 18 and it’s built off of one of Radiant’s templates
clay dining hall alt - Copy.7z (4.4 KB)


#17

I tested it on A18 stable and it throws the same error.

I think this is another case of exploding templates.
Do you remember last time that they worked? Maybe we could find hints on when were the code changes that affected this made.


#18

are you getting it with a specific template? The building that you removed was it a template? Did you just recently made an addition to your templates?

Reason i’m asking is that i’ve had a similair situation and after a lot of trial and error i noticed that one of the templates i made was braking the hole custom tab. In the end removing that one template fixed it, but its a big hassle to figure it out. Just thought i should mention it in case you had some templates you desperately wanted to keep. Otherwise just empy the custom templates from the save objects file and it should help. Atleast it did for me.


#19

thank you, I’ll try that!


#20

nothing really stands out. I was just playing through the game like normal when it happened. I removed a built building, tried to place the template where the original building was, and it broke. that’s all I can think of