[Bug] Dev 2513 (x64) Can't mine out a column

Latest Dev build 2513 (x64)

Tried to mine out columns and the workers simply won’t mine out the area if there are contained ‘non-mine’ areas. I have tried this 2 ways, I have tried designing the area starting with the non-mined areas and the workers will not start mining at all. I also tried starting the workers mining with just basic tunnels and then adding to the area using the Mine Tunnel tool to contain non-mined areas (picture below) at which point the workers stop working on the zone entirely.

Expected result:
They mine out the area and leave the ‘columns’ in place.

They will however resume mining the area if you fill in the complete mining area.

To reproduce:

  1. Use the Mine Tunnel tool and draw out an area that contains non-mined areas
  2. Workers will not work on the zone.
  3. Sadness
  4. Use Mine Tunnel tool and fill in the zone
  5. Workers resume mining.
  6. Confusion.

I couldn’t find this topic and I feel like I have seen pictures of people making ‘throne rooms’ that contained columns so maybe this is a newly introduced bug?

1 Like

It’s probably not particularly new.

If you want to leave columns behind, then just do your mining in 2 or more stages. You don’t have to do the whole lot in one go.

1 Like

Yeah, I was thinking about doing it in a few stages next. I feel like you should be able to do it all in 1 go though. Maybe its simply some AI function that hasn’t been flushed out yet.