Mining areas ignored

b01r870

#1

This has been an issue for a while now, and it’s super simple to reproduce, just make sure you’re using the tunnel tool and watching the merge areas. Simply make a bunch of mining areas, no matter how big or small. Make sure some are behind others. They will mine some of them and not others, you’ll have to remove and redraw at which point they will all run to it from doing nothing.


#2

I second this motion, i’ve noticed this more and more aswell.


#3

r870, same here. save&load troubleshoot issue but for short amount of time


#4

stonehearth.log (1.8 MB)
save https://1drv.ms/u/s!Asn3lEt-4tOhivYwWEuBzqnwQ8O75A


#5

I noticed this as well.

What I noticed is that Hearthlings tend not to mine a zone that they can’t reach immediately (so, a tunnel of two zones, where they have to mine out the first to get to the second.

What I also noticed is that I can place up to 3/4 zones before they stop mining. As in, they mine the first 3 or 4 zones, but don’t bother with the rest.

So, what I do now, I place up to 3 zones of mining max that they can reach immediately, wait for all of that to be mined, and then place another 3.


#6

The only way to get them to mine it is to set an area right next to it (that merges with it) to be mined also then they magically pick it up…otherwise redrawing is the only option.


#7

still occurs in r874


#8

Can confirm