Workers Dont want to mine 4x4x4 downwards

AI just does not wish to mine a specific way

Steps to reproduce:

  1. Empty a hall out
  2. Make a small natural stairs down
  3. try to mine the rest with the 4x4x4 mining tool
  4. ???
  5. Profit

Expected Results:
workers mine without any problems

Actual Results:
They only mine the top row.

With the single block miner it works fine. it only bugs with the 4x4x4
saving and loading does NOT fix it.

Edit: for some weird reason the 4x4x4 tool turned into a 4x4x5 tool. so 5 deep. So because the workers werrn’t on the bottom of the 4x4x5 spot. they stopped mining.
It’s still a bug that it suddenly turned to a 4x4x5 mining box though? 0.o


Version Number and Mods in use:
no mods

System Information:
Dont think this will be needed :slight_smile:

blocks are 4 x 4 x 4 when selected from the side and 5 deep when selected from the top – there’s an extra floor/roof layer.

Your bug there is because they’ve mined away the whole roof and its upsetting them somehow. Build a ladder from the bottom of the selected area to the top and they’ll climb it and start mining.

1 Like

You can also try suspending and enabling again the mining order / mining tasks in the citizen manager and see if any hearthling decides to go finish the mining.

Normally they only can do 4x4x4 but when the selection becomes 4x4x5 they are supposed to mine in a way that allows them to mine that 5th row without getting stuck.

did that already, does not work. getting rid of the mining selection and then re-making it doesnt work either :slight_smile:
So far, the only way I found to get around it is to use the 1x1x1 mining tool. Which works, but it’s obviously not preferred.

1 Like

Does anyone have a save that reproduces this problem? I replicated the geometry, but it worked on my machine.

Maybe It’s because the wall(the one being mined) has a height of two blocks, and for some reason the bearthlings are trying to reach the blocks on the top layer(they tend to consider it a higher priority to mine since they can’t mine it from ground/bottom level as it is 5blocks above)
Try putting a ladder and i’d expect it to work

that is it exactly. I have also noticed that the direction of the mining plays a role on this. When I tried mining the layer above it, they started from the center and from the top layer, the priorities are a bit confusing.

When I’m back from work I’ll replicate the situation and upload the save for use. (10 hours from now)

I made a 100% new save file on the latest build and quickly reproduced the same problem.

here you go:

tell me if you need more info :smiley:

@aMdivided - Got the save. Thanks!

Ok, found the problem. I improved the dependency graph that determines what order to mine the blocks. This will be fixed in the next patch, but you’ll have to remove and redraw the mining zone.