[Bug] Buildings wont have walls


#1

Summary:
I was building a building, and I forgot that I didn’t put a roof on it, so I decided to pause the building and added the roof. The hearthlings stated to build the roof and skipped building the walls.

Steps to reproduce:

  1. Build house, but leave roof off.
  2. Finish and initiate building.
  3. After they have built some of the structure, pause the building
  4. Edit building while it is paused
  5. Add the roof
  6. Finish up the building
  7. Laugh while the roof is built without any physical support (no offence meant as I love your product)

Expected Results:
I expected the hearthlings to continue to build the structure as originally planned and then go to work on the roof

Actual Results:
The Hearthlings ignore all previous orders and start building the roof without any structural support

Notes:
It also produced a wired bug where the hearthlings make a lot more ladders than necessary

Attachments:
Attached are two photos of what this bug produces, one of them is the ladders, while the other one is a picture of the roof being built without any walls to support them


Version Number and Mods in use:
Alpha 15 and no mods

System Information:
CPU: I7-6700HQ
GPU: Intel HD 530
NVIDIA GeForce GTX 970M [Clevo]
Memory: 8 GB DDR4
Storage: Samsung SM 951 M.2 128 GB
Hitachi Z7Kt500 Travelstar 500 GB
Motherboard: Eurocom Monster 4
Network: Killer Wireless-AC 1525
OS: Win 10 64-bit


Strange building bug
#2

Welcome to the forum, @Ohunter :slight_smile:

I think that you would have been able to add the roof after they had finished building it, and it wouldn’t have looked like Step 7 :sweat_smile: (correct me someone if I’m wrong)

Since you added the roof at step 4, I think the system considered it being a different building. Did it attach to the walls in design mode?


#3

I put down everything when first designing the building, however, I just forgot to add the roof when building, so when I realized it I paused the building and edited it. For me that seems like the AI is still considering it to be the same building, however I might be wrong.


#4

I tried to reproduce it making a building, pausing half done, and adding something to it, and they built the second part. I had to reselect the first part and tell them again to build it, because they didn’t resume it after completing the second part. Not sure about the selected building, because at some point the UI did show as if I was editing the first building =/

@not_owen_wilson might know better.


#5

So you were able to reproduce it as well? I haven’t had time to reproduce it so I just decided to report it.