Autosave folder corruption

Autosave doesn’t run over the course of 10 days ingame, it’s box however is checked and I’ve tried re-doing it.

Also the UI for what type of units you are using on the Savegame infobox is stuck on your amount of workers it seems.

Steps to reproduce:

  1. open a game
  2. play for 10 days with autosave on
  3. save your game manually
  4. check if your UI works
  5. check if your autosave made a new file for your new game

Expected Results:
autosave made a new file and I can rest my heart
I can quickly see how many workers,craftsmen and militia I’ve got

Actual Results:
autosave did not actually save over the course of 10 days
the UI only shows my worker amount

Both my fresh and old games seem to only show workers in the UI


Version Number and Mods in use:

no mods at all, release-689_x64 (latest branch steam, A20 )

System Information:

I’ve had that happen once, my autosave folder had become corrupted. If you look in your saved_games folder (default location is C:\Program Files (x86)\Steam\steamapps\common\Stonehearth do you have an auto_save folder? If so, try deleting it…

1 Like

Wow thanks a bunch !

It’s really hard to deal with the UI bug when you’re jugling saves for templates. This works around the issue but I still thought I should report the possibility of it happening to more than 2 people.

Cheers for the quick help !

1 Like

Glad it worked! I agree it is concerning that it happens, but at least the fix is simple :smiley:.