Save game not working randomly (with autosave off)

I am playing the latest version of the game and it doesnt let me save. When I play and go to menu and try saving the game, it says saving but it doesn’t save anything, and the small list of saves is empty. I can continue the game but when I quit I lose all the progress because for some reason i cannot save my world.

Im playing alpha 9, Stoneheart 0.1.0 (release 265) 64x build

1 Like

hey there @Hurkus… welcome aboard! :smile:

I think we have one or two similar reports floating around… unfortunately, I’m unable to merge (being trapped on the phone at the moment)…

@Hurkus, so when you open the save menu there’s no saves at all?
Nor the autosaves (do you have that enabled)?

No I dont have it enabled and for some reason now saving works (1 day after not working). Im sorry for taking your time, but now it works for some reason. I really don’t understand how this game works.

Now saving doesn’t work AGAIN. On day 5 or 6 I tried saving but it didn’t work. I still don’t have autosave on, should it be on or off?

If it’s off, you’d always have to remember to save manually. If it’s on, it should save automatically every 5 minutes.

People are complaining lately that saving it’s taking more time than it used to take in previous releases…

1 Like

I have autosave turned off but I still cannot save the game. It says saving just for a second. Saving only worked for an hour for me then it stopped working.

1 Like

I am having this Bug I can no save at all and it crash.
system Satellite P775-10K - Toshiba

files Dropbox -
full system and dum file.
ask if more files for the log

1 Like

Wold this bin beater in a new post?

Edit 1

(p.s I do not like this forum)

1 Like

Hey everyone, sorry you’re having this problem. :frowning: “Saving” and “loading,” unfortunately, are not monolithic features. The hundreds (or thousands) of systems that are running when you save that must be written, in a proper order, to the save file, and on load, everything that was saved must be rehydrated. If we have a bug anywhere in any module’s save code, and the game happens to be in a bad state when you try to save, the save may fail. Any time we add or remove or tweak a feature, we run the risk of introducing more save/load bugs. Though we keep fixing these bugs, we can’t guarantee that they we’ve gotten all of them, or that we’ll never introduce more, until the game is feature complete.

For your particular versions of the save/load bug, how long have you been playing the game (in-game days) before it fails to save? Did you notice any bugs or red screens before the issue happened?

Whether or not autosave is on should have no bearing on the problem.

1 Like

The number of days before the save bug seems to vary but it’s usually over 7. For me it usually happens after digging an underground mine too big or after building a stone building.

The bug happened on 5-6 ingame days, I noticed this bug:

@Hurkus, are you on Steam regular, or Steam latest? Hopefully this is fixed on Steam Latest.

Oh… I don’t have it on steam, I downloaded it on the humble bundle page when I bought the game. Should I instal it on steam?

I got a new bug:
When I go to save game menu, the saving screen gets stuck. I can still fly around if I press esc (after 1 min), but I have this save menu over my screen for ever and I can’t interact with anything. So after a few minutes I just quit.

When I searched for the Stonehearth folder, I found the game saved in a folder but when I started the game, the saved game wasn’t there. I guess i’ll never be able to save my game :frowning:

[Using steam newest version of stonehearth, bug found 23.5.2015]