[Con] Saving Not Working - Workaround Inside


#1

Title:Saving not working

Summary:Whenever i click on save town it does not save.

Steps to reproduce:

  1. Press Escape
  2. Go to Save game
    3)Click on the New save button.

Expected Results:Saves the town and you can load it later.

Actual Results:Stops for a moment but doesn’t save

Notes: It used to work for me on the test version for alpha 3 then later on that same version it stopped working.Now in the actual Alpha 3 release it still will not work.

Attachments:

Versions and Mods:Stonehearth Alpha 3

System Information:
Thanks in advance :smiley:


[Dup] Game saving don't work
#2

This is definitely an odd one.

So, you start a new game, you place your banner down and move around a little, and then press escape to bring the menu up, go to the save game option, hit ‘new save’ … and then nothing?

Do you have any save files at all? Could you get some screenshots at all? Thanks :slight_smile:


#3

One workaround might be: go to your saved games directory and remove everything from it. Try again. See if it works.

We suspect that if any of the saved games are corrupted in any way, that it prevents the save dialog from coming up correctly. Obviously, we want to find out what’s corrupting the saves, but this might help till we figure that out.


#4

Right so i cleaned all the saves

So i just started a new world with the saves cleaned.
So now im in the save menu.
Clicked on save and as you can see Stephanie’s idea worked! it now saved! Thanks alot Stephanie and Geoffers you guys are amazing and superkind, thanks for replying so fast! :smiley:


#5

No worries! Glad we could help … I say we, but it was really all @sdee. I’m always happy to take credit though :stuck_out_tongue:

I’ll mark this one as confirmed with a workaround inside, and leave it open until it’s been resolved!

Thanks for the report @HyperDioxide.


#6

thanks for the follow up @HyperDioxide!

note to self: add to workaround ad/or FAQ thread

note #2: by “self”, I of course mean @Geoffers747


#7

Title: I can’t save/load game. T T

Summary: I don’t know what happens but about 1 week ago I can’t save or load game.

Steps to reproduce:

  1. Start game with the last version.
  2. New game and play.
  3. Press “Esc” to show menu.
  4. Press “New Save” button.

Expected Results: Game will saved and show thumbnail image.

Actual Results: A bit game pause (look like saving) and nothing.


 After that I selected “Load Game” and nothing again

Versions and Mods: Stonehearth 0.1.0 Release 92, No mods.

System Information:

OS Name Microsoft Windows 7 Home Premium
Processor Intel® Core™ i7-3630QM 2.4GHz
Video NVIDIA GeForce GT 650M
Installed Physical Memory (RAM) 8.0 GB


Feedback on Combat
#8

Thank you for solution (^ ^)v


#9

Came here to confirm the bug. The workaround also works.

Thanks guys!


#10

well, thanks for the confirmation! :+1:

and the reminder to add it to the list of workarounds… :sweat_smile:


#11

YOU MAY NOT HAVE TO DELETE ALL SAVES!!! [Release 127 Alpha 4] I’m finding a little ‘workaround’ for when I can’t get a New Save to work. Firstly, I am saving New Save FREQUENTLY! Each time I do, I watch to make sure the time is changing, to confirm that it IS saving. If it does not indicate a new save, I simply exit the game, then go right back in and Continue. I’m able then to continue and do new saves. When it stops saving again, I repeat the exit/continue.


#12

I have this bug too, however it does create save files, but they seem to be corrupted and dont show up. Restarting the game and continuing from a working save does not fix the problem and it just happens again :frowning:


#13

I have this same bug also (alpha 5) I have deleted the saves that the game tries to make but still get nowhere. As soon as i hit the save button a few seconds later, no game.

I am playing this in Virtual Box w/ Windows 7 premium home edition on an iMac w/ yosemite and a 3.5 GHz Intel Core i7, 8 GB 1600 MHz DDR3, NVIDIA GeForce GTX 780M 4096 MB.
I have given Virtual Box 4GB of the memory.
I started playing on virtual while waiting for the Mac version to get done but not being able to save really sucks. I get going then have to abandon it.
Any suggestions, need any more info I have system and and application logs saved.


#14

So… here’s what we know:

Every time the team changes a lua file that records world-state data (that’s most lua files) there is a chance that we introduce a bug that causes that file to, in some circumstances, not save its world state properly. If you save while the lua file is in a buggy state, the save game that is created will be corrupted and will not load properly. Furthermore, going back to an older, working save, and then trying to save THAT game will fail, because one corrupted save file in the folder prevents all subsequent saves from working properly. This problem can be worked around by deleting the corrupted save from the folder. To do this, you have to identify which save is corrupted. If you can’t figure out which file is corrupted, then the fastest thing to do is move all your files into another folder and start over from scratch (adding back good saves that you really like).

If your save folder is completely empty, and you still cannot generate a save, then there’s a chance that this is a slightly different bug, and in that case, Team Radiant would like to know more. Exactly what happens when you try to save? Does the UI stall? Does the game crash? Does the save game just not appear in the folder? When does it happen/how many things have you done in the game until that point?

We have not tested the game in OSX in any way/shape/form, so we might be in new territory here.

Update: If you have a save file from Alpha6 latest that does not load, attach it to this thread and we’ll do our best to take a look. Note: the entire dev team is working on the build on Steam Latest, so any saves from any build that doesn’t have the blueprint splash screen has code that is probably not relevant anymore.


#15

I am still on alpha 5 until you release 6 for the humble bundle, I don’t play on steam.

At first the save files were just corrupt and I would delete them and start a new game. Then I would try to save the game and I press escape and the option to save comes up but I can’t name the save or anything so I hit save and about 30 seconds later the game crashes. There are no save files made at all. I know that I have played at least a dozen times and I know the and the last 5-6 have no save files made at all.
I have been waiting patiently for the OSX version and I know it will take time so that is why I have been trying this in Virtual Box with Windows 7 Home Premium.
I have enjoyed the game so far and I am so looking forward to the final release
I have the system.evtx, application.evtx, and the DxDiag.txt if needed, I tried to attach but error said files are too big.
Thanks for the reply.


#16

@twixiedoodle, no worries about the upload; can you find your userid? It’s in a file called user_settings.json. Maybe we have a record of your crashes from our crash reporter and can look up the data that way.

Hmm, so it used to work, the save folder is now empty, and new games still crash… what if you uninstall the game, nuke all directories etc, and try from scratch?


#17

“user_id” : "99439a73-6962-11e4-9e31-0800273e0380"
the game really isn’t installed I have to run the .exe to play the game each time., so I will delete this folder and re-download and try again and see if that helps ?


#18

Well, if the bits used to work, and now they don’t, I presume some setting cached somewhere has caused the problem to get worse. :frowning:


#19

I tried deleting the .exe and all the files I could find and re downloaded the game and played for awhile and tried to save again and the same thing, window goes blank, you can still here the game playing, and then it stops. I do have a save file that has a black screen for preview and when I try to load or resume it won’t load. I moved that file out of the folder Stonehearth and tried again to play awhile but this time no save file at all.
I think I will wait for Alpha 6 and see if it plays better and I can save. I hate playing just to lose all progress that I have made.
Thanks for the help.