[ Alpha 6 ] Unplaceable Bed bug

I’ve constructed a Mean Bed, but nobody will place it. Ever.

I’ve tried upgrading this bed, removing it, and simply moving it. The bed ghost image moves, but nobody ever places it.

Finally I tried changing the storage so the bed would be moved, but the villagers act as if the bed doesn’t exist. And yet the ghost image remains. I’m now considering what to do with the ghost image so it won’t be a distraction.

1 Like

hey there @wog_gie … welcome aboard! :smile:

I thought for sure we have seen this report, but cant seem to locate it…

have you tried running the latest alpha client, to see if the problem persists?

The latest client on humblebundle is alpha 6. Where would I find a more up-to-date version?


follow the steps outlined here to get the latest (unstable) development builds… :+1:


you got a steam key with humble. go to steam and open the properties of the game, go to beta (last tab in properties) and select latest build.

But even in latest build it still presist. i just build a small house and make it my Ghost House (Scary stuff in there)

Okay, I have the new Alpha, and the problem is now different. Beds are supposed to be built along with the stock houses, but they are not. Instead, the ghost beds remain in place within the houses, barring the placement of actual beds.

The solution (as far as I can tell) is to not use the stock house plans, but to make custom houses that do not include beds, enabling beds to be placed at will.

Beds in storage all seem to be seen by villagers, thus placeable, so that’s solved, at least.

From what I can tell from looking at the pathfinding data it looks like the houses are somehow glitching out and the AI pathfinding no longer sees the buildings or anything inside/attached. However, if you remove the door of the building using the ‘destroy’ console command suddenly the AI sees the building and all of its parts again and the beds become functional.

I’ve not had any problem with this… The only thing that I’ve seen concerning beds is that the ghost images never go away, so that you can place a different bed.

Does the removing the door trick work to fix the ghost bed problem?

To fix the ghost bed problem you just open up the build menu then go to the design custom building menu. Once there use the eraser button to remove the ghost entities of the beds from the building(s).

1 Like

ok, thanks. I’ll give this a try!