2 errors. unplaceable furniture ghost and custom building glitch

i placed this on steam but thought i would move it here. this is a link to the steam thread

to start with i am new to the game just got it a few hours ago so i may be missing something obvious, if so i appologize. my system specs are

windows 10 KN home edition
core i7 3.5 Ghz
geforce 1060
16 GB DDR3

so i should be able to handle tech specs.

i am playing alpha 23.

i’m going to start with the simple problem i crafted several mean beds and placed them. they where all side by side with half(to my embarrasment) one square lower than the other half. all but 1 got placed and my inventory showed all placed. but there was a “ghost”(outline of where it was supposed to go) of a bed where the slip of some being lower started. this never got filled and i saw no way to remove it. eventually i removed a bed next to the ghost and then the ghost was filled. i assume i did some error that made the bed unplaceable till the other was removed, but the real problem was that i couldn’t remove the ghost. it had to be filled. on a side note i don’t know if this is a bug or not but in trying to remove the ghost i tried placing another bed in the same spot. and after the first ghost got filled it placed a second bed on top of the first. i was able to remove both afterwards.

the second error is harder to explain essentially i placed a custom building and no walls/floors appeared but ghosts of the furniture showed up. and some of the items where in very odd places. i also got an engine error i did copy to clipboard and here it is

release-784 (x64)
No matching overload found, candidates: luabind::object load_json(lua_State*,std::string const&,bool)
stack traceback:
[C]: ?
[C]: in function ‘load_json’
radiant/modules/resources.lua:35: in function ‘load_json’
…/fixture_fabricator/fixture_fabricator_component.lua:372: in function ‘_get_rotation_tweak_xz’
…/fixture_fabricator/fixture_fabricator_component.lua:447: in function ‘rotate_structure’
stonehearth/lib/build_util.lua:567: in function ‘rotate_entity’
stonehearth/lib/build_util.lua:571: in function ‘fn’
stonehearth/lib/build_util.lua:172: in function ‘for_each_child’
stonehearth/lib/build_util.lua:570: in function ‘rotate_entity’
stonehearth/lib/build_util.lua:571: in function ‘fn’
stonehearth/lib/build_util.lua:172: in function ‘for_each_child’
stonehearth/lib/build_util.lua:570: in function ‘rotate_entity’
stonehearth/lib/build_util.lua:585: in function ‘restore_template’
stonehearth/services/server/build/build_service.lua:1656: in function ‘build_template’
stonehearth/services/server/build/build_service.lua:1647: in function ‘cb’
stonehearth/services/server/build/build_service.lua:1620: in function ‘do_command’
stonehearth/services/server/build/build_service.lua:1646: in function <stonehearth/services/server/build/build_service.lua:1642>

here is a little more background. a lot of this may be unimportant but too much info is better than too little. i made a custom house and saved it as “comfy custom” then i noticed that i was missing the bed in the template. i then placed a duplicate of it only rotated 180 degrees. but before finalizing it i added the bed and saved it again as comfy custom, then deleted the original. the glitch happened when i tried placeing the second comfy custom rotated 180 degrees again. i placed it close to the side of the first house i made then i got the above error. again the walls/floor/roof ghosts did not show as expected but the bed ghost was exactly where i wanted it, also the window, and some other ghosts where actually behind the first house when they should have been in a compleatly diffrent spot. looking at the error text i assume that the rotation meant something but i don’t know. i currently have a save file where this happens every time. if you want it i can upload it.

sorry i just noticed the link from steam is off. it is on the disscusions --> bug reports --> then the same title as this post