All house content erased with undo button

First of all, i apologize if the title doesn’t describe well this issue. I had no idea what to say.
So, in the building designer, i tried to connect the bearing of the door with an existing blueprint’s road. Then i pressed the undo button and all the house furniture/decorations/doors/windows have been erased. On the other side, the new road section remained intact.

Steps to reproduce:

  1. Make a road BUT don’t build it (leave it as a blueprint).
  2. Build some house.
  3. Connect the house to the road with either road tool or foundation tool (both ways give the same result).
  4. Press undo.

Expected Results:
The last step is undone (new road section removed).

Actual Results:
Deletes all the house’s stuff and the road remains intact.

The road was a bit complex and i have been working on it several times since it was a kind of “district grid”. Note that connecting the house to the road obviously merged both blueprints.

Better than images, you can see exactly what happened on my stream’s rebroadcast : here (1:07:50).

Version Number and Mods in use:
Stonehearth 0.20.0 (release 699) x64 build
Mod List

System Information:
Windows 10