[latest unstable] Deleting stuff from blueprint results in error message

Those red blocks won’t budge. Tried to connect them before with rows of blocks that lie above the wall in order to give them support and be, like, not red, but that didn’t work. “Undo” started to get wonky afterwards. Managed to undo the rows but further clicking wouldn’t do anything. When I used the eraser on one of the remainig blocks, the following error appeared.



release-838 (x64)[M]
Unknown C++ exception
stack traceback:
[C]: ?
[C]: in function ‘get’
stonehearth/components/building2/building.lua:478: in function ‘remove_blueprint’
…ehearth/components/building2/delete_structure_op.lua:30: in function ‘apply’
stonehearth/components/building2/building.lua:360: in function ‘commit_transaction’
…hearth/services/server/building/building_service.lua:224: in function ‘_commit_data’
…hearth/services/server/building/building_service.lua:509: in function <…hearth/services/server/building/building_service.lua:486>

release-838 (x64)[M]
c++ exception: lua runtime error
stack traceback:

Save file: 1525955345585.zip (4.4 MB)

Follow up: Managed to get rid of the red blocks by moving them so they’re not red anymore as a workaround. New issue: The windows are being obstructed by walls. Building won’t work. Deleting the windows gives an error message. Cutting holes into the windows lets me start the build but it stops shortly with the floor being red.

Save file: 1525969468872.zip (4.6 MB)

Tried to rebuild it with a foundation of blocks only. But there’s this one row that refuses to work. No clue why.

Edit: Seems related to the fact that it’s currently impossible to build ladders on building.