Bugged Building, Now I cant build anything

So, I was building a custom building in my town, then I got a bug report. After that, I couldn’t delete any of the parts of the building. So I restarted the game, and in a sense it worked… upon restarting the game, I was able to delete the parts of the building I was designing. However, when I went to start designing another building, I kept getting bug reports and the game wouldn’t let me build anything. Not even the vanilla buildings. I have no idea what could have caused this? I have some buildings clumped fairly close together?? Almost all of which are custom designs.

Here is the bug report…
release-737 (x64)
stonehearth/lib/build_util.lua:492: assertion failed!
stack traceback:
[C]: ?
[C]: in function 'assert’
stonehearth/lib/build_util.lua:492: in function 'building_is_started’
stonehearth/services/server/build/build_service.lua:232: in function 'filter_fn’
radiant/modules/terrain.lua:249: in function 'get_entities_in_region’
stonehearth/services/server/build/build_service.lua:227: in function '_merge_blueprints_in_region’
stonehearth/services/server/build/build_service.lua:291: in function '_add_floor_type’
stonehearth/services/server/build/build_service.lua:269: in function 'add_floor’
stonehearth/services/server/build/build_service.lua:153: in function 'cb’
stonehearth/services/server/build/build_service.lua:1583: in function 'do_command’
stonehearth/services/server/build/build_service.lua:152: in function <stonehearth/services/server/build/build_service.lua:150>

I would include the savegame But my machine doesn’t have software to zip files with and I really don’t trust any of the free file compression software sites.
Any suggestions? I love the game but the building mechanic throws me for a loop a lot of the time.

7Zip is what I recommend as it’s very light weight and makes it’s use seamless with normal file commands (right-clicking). If you don’t want to do that, uploading the whole folder to Google Drive, setting the permissions to public, and then supplying the link would work too.

But besides the save, I would also recommend posting some pics/screenshots. Maybe some of us can spot it without even needing the save. Honestly from the error above, it sounds like you’re building the two buildings up against each other, and it can’t figure out if it’s one building or two.


Welcome to the forum, @MrPenguin :slightly_smiling_face:

By any chance were you working with slabs? Building errors that completely break the editor are rare to see, but sadly they still exist.

The savefile will help diagnosing what happened, maybe there’s an extra case we have overlooked. I’ve bumped your user level so you should be able to upload files now. The size limit is 10 MB though, so if the zipped folder is bigger than that you will have to use Google drive, Dropbox, or something else.

1 Like

Okay I’ve zipped the savefile.

@SirAstrix, Yes I was using slabs, I actually started having the problem after I tried putting a slab piece on the building. I was going for a shed sort of thing that I could draw a stockpile zone inside of.

1503896912231.zip (6.2 MB)

1 Like

I can build new houses in your savefile :thinking:
Is that from before you got the bug, or from after?

Really?? Strange… That save file is from after I restarted the game and was able to delete the bugged building I tried to build. However I still cant build stuff. When I build a templated building it just doesn’t appear and when I try to build a custom building I still get that bug report.

I seem to have figured out the issue. I’m not sure how, but I’m able to build again?.. anyways, the issue occurred after I accidentally tried to place a slab inside of a was while I was designing a building

1 Like