All Combat Hearthlings chasing one Hearthling

EDIT: Please hold this, I’m not actually sure this is to do with ACE at all. I’m doing some research into it right now. If you don’t hear back from me, assume this has been resolved.


All Combat Hearthlings engage in combat with one of the Footsoldiers, who continues their usual duties. When they reach the Hearthling, they do not attack, stop engaging in combat, then re-engage the friendly Hearthling around 1/2 second later.

Demoting the Hearthling to a non-combat role causes the combat hearthlings to choose a new Combat Hearthling to engage with them.

Turning off their job will cause their behavior to return to normal.

Steps to reproduce:

Unfortunately, I haven’t seen this bug before, and cannot advise any steps to reproduce. What I can say is this began to happen after the update which removed default patrol behaviour when the Job was enabled.

Expected Results:

Hearthlings should only engage with hostile entities.

Actual Results:

Hearthlings enter a loop of chasing, in a large group, the designated Hearthling.


I had limited success unpromoting all the combat hearthlings. Not long after, however, my game crashed, likely due to me removing the Patrol Points mod or some other stonehearthy reason. Until then, the game had been stable.

Attachments: #

Version Number and Mods in use: ACE pre-release

ACE Fireplace house
Ace Mod Composting
Age of Giant - Piles
Life’s a Beach! Archipelago builds
Archipelago Biome extended templates
Authorised Community Expansion (ACE)
Autoharvest Mod
Box Command Tool
Dani’s Core Mod
Don’t climb on the table
Fisher Job + Archipelago Biome
Follow Cam Remembers
Follower Camera Angle Tweak
Windmill Mod
Breskin’s Tents
Functional Workshop Signs
Patrol Points
Piles Plus
Sacred Grove Biome
Settlement Decor
Silverthorn lvl 1 Buildings
Specialised Loadouts
SWADER’s Basic Shops
Swords AND Plowshares

(As an FYI, I tried removing the Patrol Points mod from the list. I didn’t have any deployed.)

System Information:

I should also mention that this bug only seemed to occur at a much later stage, when I had acquired Knights and Clerics and Archers. I do not know at what point this bug triggered, apologies.

So let me get this right, your milirary job hearthlings are attacking and hurting each other?

Not quite.

From preliminary testing I believe this to be an issue with a separate mod, patrol points.

They run up to a friendly herthling in the same way an attack order to an enemy would, and as soon as they are in combat range they disengage for 0.5s and then re-engage the target.

Aren’t they just patrolling?

No, they are engaging one herthling in combat and then disengaging when in combat range, and then re-engaging. They’re not patrolling.

Loading your save, without mods, and it worked fine, you had only one footman, he was idling and noone was following him. He was also not patrolling, but he started doing so when i created a new stockpile zone (they patrol around zones)
So, either your previous zones were bugged (not likely). or one of your mods was interfering. Probably the “swords and plowshares” which effectively touches combat stuff

These mods are either incompatible or not needed with ACE

Not saying this is what causes the problem, but I’m sure it can cause other problems :slight_smile:

Also, it’s possible they’re just trying to follow the patrol leader. The game (this is a base game issue) has this silly thing where soldiers when running will always say “engaged in combat” or (if going after the patrol leader) “chasing ”. They’re not literally going to fight them, however. It’s just that they reused these action texts.

My guess is that they are trying to patrol but failing for some reason. Could be a conflict with the patrol mods, and maybe you’ll have to demote and repromote all the soldiers AFTER loading the game with the mod removed to fix that.

Finally, ACE has its own patrol system, if you need patrol points :slight_smile:

Hey, thanks for the help guys. Appreciate you looking at my saves.

I’ll admit, this issue was weirdly inconsistent. I also reloaded the save and had the issue disappear. I did see someone mention this issue in 2019.

I’m pretty sure this was an issue with Patrol Points, which I’ve now removed. Haven’t had the issue since.

Which was a shame, because the mod removed the patrolling behaviour and allowed footmen to do worker jobs, which was easier than removing the task labor from them.

Anyway, happy for this to be closed, thanks again for your assistance :+1:

1 Like

ACE has a very handy/helpful button for toggling job on/off so you can have your soldiers help more easily :slight_smile: when you select a soldier (or the entire party on the combat screen) there should be a “scroll” with a pause/play button on the portrait (bottom left of the screen)

You can use this button to quickly switch “Job” on or off for the soldier selected (or the entire party at once)