After update to Alpha 9 Stonehearth never start


I have played game before and when comes Alpha 8 (I think from Alpha 6). I bought it in Humble store and connected to Steam. It has been running nicely with some ingame warning and errors, but after updating to Alpha 9 game will not start anymore. Every time I try to run it, it fail with Assetion Failed Error. Window open, game music plays but black window and this error. I tried some ways that is described here:

  1. restarted Steam
  2. uninstall and reinstall game
  3. uninstall, delete residual files and reinstall game
  4. uninstall, download installer from Humblebundle and install
  5. restarted PC
  6. prayed…
    (First two is for Steam)

I have tried above things and all failed with same result:
Assertion Failed: c > 0 && c <

Is there anything that I forgot in list above? Maybe changing version from 32-bit to 64-bit, but I have read here about changing it ingame and I can’t even run it. :smile:

So any suggestions how “mend” this issue? Because I want try Alpha 9 and I’m getting more excited about this game from my purchase on…

Thanks for replies, Jim4White

Did you go into your hard drive and deleted the Stonehearth Folders your self or just tell steam to delete content?

I downloaded the ZIP file and unzipped it in a folder on my desktop and ran it from there, didn’t mess with any installers

Deleted by myself. Base uninstall was by steam, yes, but then i go to the steamapps and deleted it. Then i tried install again (by steam).

I give a try to zip file.

1 Like

Are you running the 32bit version or 64bit version of the game? 32bit has become (for a lot of folks) entirely unplayable due to stability issues and is known for crashing right on startup.


I don’t know, I have only updated game on Steam. Maybe ther is 32bit version. I have looked up on Steam where to change versions, I have heard about it, but I havent found it. So only updated game and it ceased to work. Tried that list in first post. If I want to switch versions, where can I do that? I have read here on forum in another post about possibility changing ingame, but I can’t get to menu, I have that error and black screen about 2 second after hitting “run” (error is fully rewriten in first post too).

Edit: Ok i have looked up in Stonehearth folder, founded x64 folder and used Stoneheart.exe. Then, unexpectedly, it has ended with same error. If this is 64-bit version I can’t run this too.
This version of game was zip file from Humble bundle so I can’t use any version (steam, HB installer, HB zip file).


Have you tried executing the game manually (double clicking the .exe) of both 32 and 64 bit version?

I think for some people the version that works is 32, for others is 64, so…
And there’s also people that can’t run it via Steam but they can do it manually. Though you have tried practically every possible combination of reinstalling already :sweat_smile:


In the game folder, open user_settings.json in notepad and change this line towards the end to false and see if the game will run:

“enable_64_bit” : true, (change true to false). if this line isn’t there, you can add it right before the last curly bracket.


Tried it with HB version (zip) and also with Steam. Doesn’t work… I have searched for some log file and found it (easy to find :smile:) stonehearth.log (5.3 KB)

It seems like it is missing something… Stonehearth could not find lua.

Edit: Sorry I forgot at you:

Yes, last time. tried NonBritGit hint, but no succes.

ok … have you tried to disable your firewall/virusscanner? it looks like stonehearth cant get online ^^

Nope, but I’ll try that when I get home from work. It reminds me of another game… But I remember same issue, not name.

Edit: Thanks man, it works. And now I know what is responsible about that: AVG anti-virus. From now on I try to do not forget about firewall and anti-virus. Now I will look up for enabling Stonehearth in AVG, because i really don’t want every time disable it.

I think that this post can be closed. Reason of this issue has been found: Problem with antivirus software (namely AVG).


no prob ^^ normal issue with avg - because he doesnt give feedback ^^ i have avast and he always ask me what i want :wink:

I have to say never in my life have I had to disable my anti-virus to play a game. (I currently have AVG too)

1 Like

hey there @Jim4White … welcome aboard! :smile:

are you 100% certain that this was the measure necessary to get Stonehearth working?

paging @sdee … have you seen a scenario like this?

I’m glad it’s working! I agree that you shouldn’t have to disable your antivirus to get it to work, though. In general, A9 automatically moves you onto the 64-bit version if you have a 64bit computer, but this is causing some grief with some intel drivers. Chris is fixing this. I’m not sure what the intersection might be but on next update, hopefully you should be able to have your anti-virus running AND play the game. Fingers crossed!


no you mustn disable avg but you must go in the settings and allow stonehearth … like i sayed its not the antivir its the firewall :wink: AVG dont give feedback and ask if a program is allowed to get though the firewall (i think only the securitypack ask this) ^^

Understood, but Stonehearth shouldn’t get blocked either way. Almost every program you use talks to the internet for something (unless you’ve got it set to block everything). (AVG isn’t blocking Stonehearth on my machine, BTW)

? first you say you must disabled avg and now its not blocking? … ok i havent avg but like i think also the freeversion has a firewall and blocks some ports - which are used from stonehearth … i dont think its the antivirpart of avg who blocks stonehearth^^

Thanks for welcome and yes, it worked for me. But I must say, I have only Free version of AVG and maybe it is a problem, I cant change firewall (if it has some lite version in free). So I must before start Stonehearth disable AVG, but after start, it can run.

About me: I have Free version of AVG…

hmmm ok i have checked it the free antivirus hasnt a full firewall he blocks only some ports soooo that the bad trojaner cant use them … not fine you cant open the block until you buy the internet security package -.- nice badass tool :stuck_out_tongue:

I’ll go to ESET, buying this week. And hoping I do not broke anything :smiley: