(A22) Placing slabs on free-standing columns creates a "new building"

The game forced me to create a new building whenever I placed my slabs on columns created through free-standing.

Steps to reproduce:

  1. Place walls and columns, through free-standing tool
  2. Place slabs on the side of the column.

Expected Results:
Building slabs on walls or columns forces a “new building” construction.

Actual Results:
Only columns are affected.

Didn’t tried this on automatically placed walls. It was all through free-standing tool. I would delete these interloper slabs whenever it forced into creating a new building. This happened previously with my personal “Carpenter’s Town Shop” prefab when I tried adding detail underneath.


Version Number and Mods in use:
release-763 (x64) | No mods (vanilla)

System Information:
Windows 10 64 Bit | Intel® Core i5 CPU 760 @ 2.80 GHz | 8GB RAM Memory | NVIDIA GeForce GT 730

1 Like

For now, a workaround could be trying to connect it to the rest of the build with other slabs, and then remove those extra slabs.

1 Like

I’m sure there was a similar report about this. Something when trying to make balconies and the like.
Maybe it’s intended, or maybe it’s a bug. Hopefully the new editor won’t be so picky about the placement of slabs.