Can't remove slabs

I got a very strange bug during this episode i recorded today i basicly was designing a new house and was adding columns to it and for some reason when i made the second pillar outside the house it started putting slab on the other pillar that i did not even click on and these things are now locked there with the design thing and i see no way to remove these slabs. There is no “build” or “remove” and i’m pretty sure that “destroy” in the console will not help since the thing is not built it’s there transparent in the building mode.
Steps to reproduce:
Try to add slabs as a pillar outside a house. i think this is a bug that dont happen often at all so might be hard to reproduce it.

Expected Results:
Being able to remove the bugged slab that’s not built
Actual Results:
Stuck slabs that i can’t remove so i cant start a new building at that spot in the world

develop-3002 (x64)
stonehearth/lib/build_util.lua:335: assertion failed!
stack traceback:
radiant/modules/common.lua:237: in function 'report_traceback’
radiant/modules/common.lua:248: in function <radiant/modules/common.lua:242>
[C]: in function 'assert’
stonehearth/lib/build_util.lua:335: in function ‘can_start_blueprint’
…earth/components/fabricator/fabricator_component.lua:768: in function ‘_start_project’
…earth/components/fabricator/fabricator_component.lua:548: in function ‘_updates_state’
…earth/components/fabricator/fabricator_component.lua:537: in function 'obj’
radiant/modules/events.lua:73: in function 'instance’
radiant/modules/events.lua:206: in function <radiant/modules/events.lua:200>
[C]: in function 'xpcall’
radiant/modules/common.lua:257: in function 'xpcall’
radiant/modules/events.lua:200: in function 'trigger’
radiant/modules/events.lua:269: in function '_trigger_gameloop’
radiant/modules/events.lua:320: in function '_update’
radiant/server.lua:62: in function <radiant/server.lua:58>

Tried to save and load game without having any success other than throwing me a huge error message.
After this bug occurred the “revert” tool is no longer working which is pretty annoying.
Strange thing now after restarting the game and loading the error message is still there but the blocks are gone.


Version Number and Mods in use:
Latest Alpha 17 Develop 3002
Settlement Decor Mod
Spiros Windows
Jomaxro Doorways

System Information:
i7 920
AMD 7950
Samsung 840 EVO

That was an odd one to watch. Didn’t really catch what was going on, but have theory. Although odd sounding, it seems like it tried to merge with the town square, since when you accidentally got it the pillar was not connected to the intended building. By the time you noticed it was far past the undo button to account for.

Seen something like this happen to someone else, but in a prior version; where things merged for no reason. That is only theory though. Don’t know actually what happened there, but is my best guess; and since the plaza was already finished I guess the blocks figured they were finished as well… or got confused. Maybe… At least you went a bit more careful on the carpenters house. :slight_smile:

1 Like