[A19] Unable to Erase Roads/Floors

Hey ya’ll, latest alpha build (3181) and all that good stuff, rolling a save over from A18.

I hopped in to start building some more today in my existing save and found that I cannot erase any kind of ground-related drawing. Put down some floors/roads in a the wrong place? Gotta finish -> remove the structure while it’s still in the designer in order to fix it.

I’m not playing through steam right now, for the first time (just running through the executable) though I doubt that would actually have an impact like this. I haven’t gotten any errors to far besides AI spinning stuff, and even then it’s just critters just getting stuck in places they don’t belong.

Still on my 4790k/1070 rig, if that data is even still relevant :stuck_out_tongue:

If the save or screenshots would be helpful just let me know - like I said, I’m not playing through steam and I’m not familiar with stonehearth’s screen capture system.

Hmm…I can’t repro this.

I tried the following:

  1. Switched to A18.
  2. Created new game, designed floor with multiple colors.
  3. Saved the game.
  4. Switched back to A19 3181.
  5. Reloaded save.
  6. Successfully deleted sections of building.

Did you do anything different? Also, the save would e useful, please do upload it.

I took a break for a bit, restarted the game a little while ago, and now I’m not encountering the issue. I hadn’t seen it before, and I’ll post in here again if I encounter it again, but I’ll upload my save again for thoroughness. It’s strange, because while this problem was going on it persisted through multiple structures, I was able to have a building complete successfully, and it consistently required that I destroy the entire design in order to do anything with the floor, so go figure. Maybe it my desktop was just being grumpy for a little bit.

Be aware, it’s a later version of the poofing save you already have, so you’ll need your desktop again :stuck_out_tongue:

Link: IndestructibleFloors.zip - Google Drive

1 Like

Alright, update for this. Looks like it’s back, for some reason. The problem persists through a reload, and I’ve got another save for you (apologies for starting in slice mode, I fat fingered the hotkey while tabbing out and it autosaved, but I want to get you something I know is demonstrating this problem).


I have no idea if that video I tossed into the other thread was helpful - I would be happy to get you a little clip of this while it’s happening, if you would like.

1 Like

Wait a second, I think I found your problem.

Erasing floors and roads from design mode is not working if you’re building on a lowered area (those trenches that appear on the map at world generation). I wonder if it’s related to the bug where you can’t erase underwater…

Maybe the designer tries to erase at the wrong height and thus displays an X :frowning2:

Also, the ground is not restored on those areas if you remove a building.


fairly sure its related to the water bug i ran in to it once or twice as well i think the other bug report i made recently is related to that as well to be fair.


Looks like you were right to move this, I haven’t encountered this issue since updating. Thanks for all your hard work!

1 Like